Crash on macOS Sierra [DEF-2126] (SOLVED)


I tried to run Defold on macOS Sierra and it crashes on startup. Is there going to be any support for it or will I need to wait until the official release of the new OS?

Defold 1.2.89 has been released

Well, since Sierra just got released in beta, and the beta releases can be quite unstable, I don’t think we’ll see any official support for it until it is released.
Of course, if we get a chance ahead of time to try it out, we’ll look into it.

Do you happen to have a callstack of something that might help us pin point the issue?


I don’t have it available right now, but I’ll send it to you later today.


Hi Mathias!

I have exactly same problem. I can’t launch Defold on macOs Sierra Beta 3. Here is a crash log:

Defold Crash Log on macOs Sierra Beta 3


Thanks @Radzievskyi!
We’ll see what we can do in terms of being proactive and support it before Sierra is released this fall.


Any update about this issue? The final release of macOS Sierra is about to happen.

Is there any workaround, beta version or older version that works?


Defold starts fine on the released Sierra.


I updated to the final Sierra release and it keeps crashing if I start it by double clicking the packaged application. When I run from the Terminal it starts. Here is the info it reports on crash:


Yes, I have same bug same before. Defold still can’t launch on Sierra. I download latest version of Defold today. 2 months with this bug…


@Radzievskyi Can you help us reproduce the bug? It starts fine when we test here.

Have you tried to reinstall Defold?


Where is your Defold installed? The report says:

Path:                  /Volumes/VOLUME/*/


I just download it, and in download folder Sierra unzip automatically in folder “Defold-macosx”, I open folder and start, allow Open it, and get crash:


Right now I move folder with Defold from Download to Application, anyway have crash when try launch Defold.


Ok, thanks for the report. This is an issue when installing the Defold app fresh on Sierra. If you have the app on the machine and then update to Sierra, it starts fine.


Is will be fixed?


Of course. I just created an issue, DEF-2126


Thank you! I will wait :slight_smile:


Sorry for the delay. Before posting my previous reply, I tried to download it again and just extracted the package, which created the directory /Users/samflores/Downloads/Defold-macosx.

After I successfully run it from the terminal I tried opening it again by double clicking and the same issue happened, but curiously today it’s working fine :thinking:


Having the same issue of it crashing on my mac when starting and I tried 4 different time and all crash when opening after download.