Defold 1.2.89 has been released


#1

Defold 1.2.89

We have now added support for Spine nodes in GUI scenes. Similar to the component version, this creates a GUI node for each bone in the spine instance, which come in handy when you want to parent other nodes to your spine bones. A couple of new script functions has been added to the gui.* namespace, such as gui.get_spine_bone, gui.play_spine and gui.cancel_spine. The argument list for the two latter functions are the same as for their spine.* counterpart, except they take a GUI node as first argument; namely a spine GUI node.

The profiler (toggled via toggle_profiler) has been fixed and should now display the same information on all platforms.

We have also worked on memory leaks and performance issues which will result in better performance for all games, especially those with massive amounts of game objects.

Engine

  • DEF-1528 - Added: Spine support in GUI
  • DEF-2111 - Fixed: Spine events were incorrectly sent to the completion callback
  • DEF-2034 - Fixed: Profiler missing some information on different platforms
  • DEF-2084 - Fixed: Missing GUI node size enums in script
  • DEF-1983 - Fixed: Memory leak when creating and/or deleting game objects

Memory leak when spawning new game objects (SOLVED)
Changes in spine.play callback (SOLVED)
Gui.set_size_mode() is missing constants (SOLVED)
#2

#3

The size check script reports a slight increase in executable size:

And the raw data (in a nice human readable format thanks to GitHub):

https://github.com/britzl/dmengine_size/blob/master/report.csv


#4

HTML5 minified + gzipped size for 1.2.89 is 1200685 (1.2mb)

1.2.88 was 1195195 (1.19mb).

5490 diff, pretty close.


#5

Docs are also updated now with a new manual on Spine GUI nodes. The GUI docs have also been restructured a bit. Check out http://defold.com/manuals


#6

Something wrong with ios bundle. Package is too small - few kilobytes.


#7

Are you sure? I’m almost 100% sure that we have teams here at King who have bundled for iOS using 1.2.89.


#8

Yes, I made the ios bundle for standart project (just empty project what I use for Build size. Auto Stripping or manual configuration )


#9

I’m unable to reproduce this. I bundled an iOS app from the editor just now and it’s bundled with a reasonable size. Do you get any kind of errors? Have you tried bundling from the command line? It’s more complex of course, but it would be interesting to see if you get some kind of error.


#10

I reinstalled defold editor, and now defold.app doesn’t start at all (
all this bugs after update to MacOS Sierra, I think.

error.script (37.5 KB)

UPD1: As I understand it’s the same bug like Crash on macOS Sierra [DEF-2126] (SOLVED)
What can I do now? Maybe somebody know some workaround?

UPD2: it’s working when I open app using terminal
open Defold.app/Contents/MacOS/Defold


Crash on macOS Sierra [DEF-2126] (SOLVED)
#11

I’m on Sierra. I’ll see if I can repro your bug on my machine. The new install error you get is being worked on. Hopefully fixed soon.


#12

If you are in a state of panic and really need an old version here is how you do it


#13

Could not repro the bundling bug on Sierra.


#14

After new install I am using
open Defold.app/Contents/MacOS/Defold
for start Defold (double click by Defold.app doesn’t work)
and all works fine - ios build is ok


#15

Ok, good. Weird bug though.


#16

Yes, this is part of the 1.2.90 beta and should be released to stable next week if I’m not mistaken…


#17

OS update was a big mistake
As I told I’m using
open Defold.app/Contents/MacOS/Defold
for running engine.
And I can’t build android app =(


#18

Android app build is fixed and will be part of 1.2.90.