Continual Redirect to Login with Google


#1

I had an issue logging in immediately after creating my account. I would hit login with Google and then click my account and it would redirect back to the login screen again. I was getting an error saying something like:

      Content Security Policy: The page's settings blocked the loading 
        of a resource at https://ssl.gstatic.com/...

I ended up “fixing” it by adding this to the head of the page before logging in:

<meta http-equiv="Content-Security-Policy" content="default-src *; style-src 'self' 'unsafe-inline'; script-src 'self' 'unsafe-inline' 'unsafe-eval' http://ssl.gstatic.com">

Just wanted to let you guys know.


#2

Huh, interesting.
Let’s ping @samuel.nystedt and @anon18330549 to let them know about it.


#3

Hey @jirwin.dev thanks for the report. Which browser and OS are you on?


#4

Firefox 62.03 (64-bit) on Windows 7

Edit: Though I had the same redirect error in Chrome Version 69.0.3497.100 (Official Build) (64-bit). I just “fixed” it in Firefox.


#5

Had the same issue here. Enabling third party cookies seems to have fixed it.


#6

I think I’m having the same issue, Windows 7.

In Chrome 68.0.3440.106 I get stuck in a login loop. In IE 11.0.9600.18893 I just get “Google authentication failed!”.

Cookies are already enabled, and eh… I don’t know how to “fix” it like jirwin.dev did :sweat_smile:


#7

ping @samuel.nystedt


#8

@asvegren, @jirwin.dev, @Ben_James I don’t have a Windows 7 machine at the moment but tested on Windows 10 – IE11, Edge, Firefox and Chrome. The only issue I found is that IE11 sometimes blocks the Google login popup. Could you try cleaning out your browser cookies and see if that helps?


#9

That didn’t help for me. I also downloaded Firefox (didn’t have it on this machine previously so assume cookies shouldn’t be a problem) and I got the same login loop I get on Chrome.


#10

I tried on my phone (Motorola Moto G4, Android 7.0, Chrome 69.0.3497.100) and get the same login loop there too.


#11

Are you on a WIFI network or mobile?


#12

WIFI. Switching to mobile has allowed me to log in.


#13

Works normally for me (Firefox, Win10) provided third party cookies are disabled. Still loops when third party cookies are enabled.


#14

Interesting, is this an office or school network?


#15

Neither - at home!


#16

This is all good leads, thanks a lot for helping out. @asvegren, @Ben_James, @jirwin.dev do any of you guys use ad or tracking blockers like PrivacyBadger or AdBlock?


#17

Nothing of the sort for IE, Firefox, or my phone.

I use AdBlock in Chrome. If I run AdBlock as normal (which includes an exemption for defold.com), I see this when inspecting the Google login popup:

If I pause AdBlock entirely, I do not get the above error, however I still get the same login loop.


#18

I use uBlock Origin, Ghostery and Disconnect. Disabling all three doesn’t affect the behavior of the login though. Having third party cookies enabled or not still does.

On a side note: upon launching Firefox this morning, it appears a bunch of new content blocking features have been added to the latest version of the browser (v63.0), mostly to do with trackers.


#19

@asvegren, @Ben_James, @jirwin.dev we just released a fix that should help resolve the login loop issue. Let me know if you still experience problems.


#20

The issue seems to persist for me, unfortunately.