Color discrepancy from GIMP to defold [SOLVED]

#1

Hi!

When I import images into defold, the colours sometimes slightly change. What format do I need to be creating the images so that defold displays the colours accurately?

0 Likes

#2

It’s probably because of colour profiles. Try converting to sRGB before exporting (or unchecking embed ICC profile if you have such an option).

2 Likes

#3

I believe Gimp is sRGB by default. But in any case, the .png looks good in preview. It’s only when i import it into Defold that it changes. Here you can see the difference of a purple colour in Preview and in the editor (in the actual game, it is the same color as in the editor)

38

0 Likes

#4

Can you upload the raw files?

0 Likes

#5

20

0 Likes

#6

colour space is RGB there. I am looking into this (and learning about colour space!)

0 Likes

#7

That image is 8bit indexed colors, which tends to cause problems. Change to RGB 16bit and it will probably work as you expect.

2 Likes

#8

Or just regular 8-bit RGB. 8-bit RGBA is the most common format (that makes it 32-bit per pixel)

2 Likes

#9

Okay!
thanks team!

Once again I am bedazzled by how much there is to learn about all of this. I’m also noticing, for example, how simple the audio engine is, which is the one thing I’d be able to more-or-less understand.

My next issue is that GIMP doesn’t let you change this. Preview doesn’t even let you see that information. So, how can i change the color depth? Any online tools that can help? I accept GIMP plugins.

0 Likes

#10

Can you do Image -> Mode -> RGB?

1 Like

#11

RGB is already selected by default. I am downloading the latest version of GIMP to see if more options are available (I am currently using the 2015 version!)

edit: Okay, I have tried exporting with 8bpc and 16bpc RGBa, and neither have worked.

1 Like

#12

…okay, I have tried putting a screenshot of my game straight into my game and it’s worked fine. So Gimp is clearly the problem (editing the screenshot apparently causes the problem). I will continue to investigate.

edit: importing the screenshot into GIMP gives you a couple of options, basically Convert and Keep. But it doesn’t matter which you select. I’ve tried converting and keep and exporting in both 8bpc and 16bpc. Still nothing…

@Pkeod: can i ask what tool you used to see that it was 8bit indexed? Thanks

0 Likes

#13

I managed to verify it in Photoshop;

And solved it by exporting the image from gimp using these settings:

Results in this mode in Photoshop:

3 Likes

#14

okay!! The save colour profile option was not available to me in the old version of Gimp, everything works fine now. Thank you so much to Sven and others who have helped me. I tend to think of myself as a competent computer user, and every day i realise it is not the case.

1 Like