Collision mask lining up in scene editor, but not in game (Solved)


#1

I’m having trouble figuring out why my collision objects don’t appear correctly in a running game. In my first image, you can see the green “rope” collision boxes clearly overlapping. But in the second image (a running game), the boxes do not overlap, and the one on the left is not correctly positioned (right of the sprite as opposed to the left).

Is there something I’m missing about collision objects that could cause them to move away from the sprite in the scene editor?


#2

Are you scaling game objects containing collision shapes at run-time? (we currently do not support this)


#3

@britzl not intentionally. I’m not scaling anything programatically…are there any options or configurations I should check that might be scaling objects?


#4

@britzl I wasn’t scaling at run time, but I was scaling at build time (but only slightly). When I took off this scaling, everything worked as expected.

Out of curiosity, is it on the roadmap to support collision masks on scaled objects, or is it just assumed to not work with scaled objects? I would think there would be warning (or just not allowed) since the behavior is pretty unpredictable. Regardless, thanks for your help!


#5

What do you mean by this? Did you have some manual step where you scaled your graphics before building?


#6

@britzl Maybe I’m just confused how the editor works. I assumed any property set in the “properties” panel in the editor would take effect at build time, not run time. It was there that I set the scale to be something besides 1. Perhaps those properties actually take effect at run time?


#7

Ah, I see. Any change in properties should be visualized in the editor and used at runtime. If there’s a discrepancy between what’s seen in the editor and what’s seen at runtime it could be a bug.