Cannot run program "home/admin/.Defold/.../x86_64-linux/bin/luajit-32": error=2, Folder or file does not exist [SOLVED]

This error message started to print down to the Build Errors in Defold (vs. 1.3.6). Don’t you know, how to fix it?
Thank you.

1 Like

Does the file exist on disc?
If so, can you run it from command line?

No, it doesn’t exist.

Can you share editor logs (Help → Show Logs)?

I think we need the info inside the latest log file, not just an image of the log files.

1 Like

Yes, sorry if that wasn’t clear, I meant log file contents of the latest editor log file (editor2.2022-09-20.log)

I am sorry :smile:
log.txt (114.2 KB)

I made .txt from it, because .log is not possible to upload here, if it is not a problem.

1 Like

Hmm, the logs say it unpacked luajit-32:

2022-09-20 13:27:42.533 8052 [Thread-3] DEBUG com.defold.libs.ResourceUnpacker - unpacking '/_unpack/x86_64-linux/bin/luajit-32' to '/home/admin/.Defold/unpack/f22a4aca3c5770ddb27545067491c603723335f1/x86_64-linux/bin/luajit-32'

and there are no errors in the unpack process… So at that path there are no files? Also, is it possible you run 2 instances of defold editor at the same time with different versions?

Ok, so this is a breaking change from before.
The issue is that luajit-32 is now a 32-bit executable (due to the ways luajit is built), and needs to be able to run on the 64-bit Linux OS.

The current fix is to install 32-bt support, by running this in the linux terminal:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc++6:i386

We’ll talk internally to see if there is a way to circumvent this.


Thank you very much

(This worked for me (Fedora):

sudo yum install dpkg-devel dpkg-dev
sudo dpkg --add-architecture i386
sudo dnf update
sudo yum install redhat-lsb-core.i686