Cannot run my game in iOS simulator

I’ve installed my game to iOS Simulator:

xcrun simctl install booted

But I cannot start MyApp in Simulator :frowning: Crash… No logs… No errors…

When I install to real device via Xcode/Devices, my game works very well.
How to run my game in iOS Simulator?

Oh, I don’t think I’ve ever tried running in the iOS simulator. I’m thinking that it won’t work since the ipa and the bundled engine and LuaJIT version are built to run on an ARM CPU. The simulator doesn’t actually emulate the ARM CPU does it?

Yes, ipa doesn’t work in simulator. But *.app file should work in simulator.
I’m trying to start *.app file.

Isn’t the app version ment to be used on Mac OS and not iOS?

Yes, generally

ipa = ios
app = macos

I believe I tested xcode simulator and it worked but I may be mistaken… putting back on todo to test again. (Misremembering from working on too many projects)

@britzl is right. You cannot run your game in iOS Simulator.

Can the ios builds work on the iOS simulator now?
I’ve been trying to run my build on a simulator but it crashes at opening.

Yes if you bundle for the simulator.

I think there is an issue with ios simulator build.

Ugh, I missed that one.

OK, I tried with Defold 1.2.173 and had the same issue though.
Will wait for a patch.

Checking on this issue. Built with v1.2.177 still crashes the game on start when run on the simulator. Is a fix upcoming?

I’m asking because Apple keep rejecting the game stating issues on different devices each time. It would be handy to be able to replicate the issues without having to buy the device!

Sorry, no progress yet. I hope to take a look at it this week.


I noticed this issue has been closed, so I giddily went to make a new build of my game, but sadly it crashed.

I thought it might be an issue with my project, so I also tried the defold dev one,, but, alas, with the same result.

What version of Defold you are resting in?

It’s fixed in 1.2.192:


Gah, that’s it! I was using 1.2.191. Will try again when the new build is out of beta.

Edit: This works great with 1.2.192. Nice!