[CANCELLED] Spine / How to play animations that are inside a folder?



test/walk, test-walk and test_walk… don’t seem to work

How to get the animation name?

Thanks :slight_smile:

Seems like it has nothing to do with the anim name…
(since new anims don’t work anymore on Defold, even super simple or duplicated ones)

Probably more with the recent Spine update (4.1):

(not 100% sure but very likely)

A small reminder that this is vacation season.

One of the reasons we moved this code into an extension, is to make it possible for our users to not be blocked by our priorities/vacation etc.
We’ll happily accept pull requests as usual.

If waiting is not an option for you, we suggest sticking with the supported 4.0 version.

1 Like

Oh ok, I didn’t know the team was currently on vacation!

Unfortunately, I’m not skilled/experienced enough to do it myself… but there is no short-term emergency, I can work on other topics.

I already tried to downgrade to Spine 4.0, but it didn’t work… I could open an old version of my Spine file but would lose ~50% of my animations. So, until I’m forced to do so… I’ll wait.

Do you think the update could come in 2, 5, 10, 20 weeks? Just to have an idea.

Anyway, enjoy your well-deserved holidays! :sunglasses::beach_umbrella:

Ah, so you were using a Spine 4.1 feature? As I answered in the “Upgrade runtime to Spine 4.1” issue there are no immediate plans to work on an upgrade. It might be as easy as to download and build with the latest runtime from Esoteric, but I don’t know.

Some team members are on vacation. And others, like me and Mathias are traveling to the “Develop: Brighton” conference to give a talk next week.

Thank you for your answer!

Probably, but I’m not sure which feature… :thinking:

Ok I see.

I just checked my Spine repo and identified the latest 4.0-compatible version. It was 7 days ago… But at this time, I struggled hard creating some animations (since I’m not a professional animator), and now I have animations to “duplicate” so… All-in-all it may be much faster this time. Frustrating but faster.

I shouldn’t have upgraded without asking here first, so… let’s say this is my punishment :nerd_face:

Have fun in Brighton, then! :slight_smile:

1 Like

But you shouldn’t have to recreate the animations. You should be able to re-export them with the correct runtime version set in Spine.

1 Like

That’s what I did yesterday (and today) if you’re talking about that:

I receive a quick warning message:

I say to myself “ok, this is just a warning…”

But some animations are not recognized in Defold, while they are in the Spine project:


The “death” anim is an old one that was working fine when I was using Spine 4.0 (like any of my other anims).

For some reason, animations seem to be “randomly” affected… Some are working while some others are not. I’ve identified some weird behaviors, like: if I duplicate or rename a functional anim, this animation will stop working… and work again if I delete the copy (/ rename it. So fuck*** weird.

=> works
=> doesn’t work (Spine json exported, name changed in Defold)

The whole thing seemed so broken that I thought “ok ithe spine_json is messed up when I use Spine 4.1 and export to 4.0… so let’s re-create a clean basis even though it takes time.”

Not sure it comes from the downgrade, but this is not something I’ve experienced before… It’s like a playing with a Rubik’s cube. This is driving me crazy…

Are there guidelines/best practices related to animations ?

Should I avoid using folders? (!)

Should I avoid renaming animations ? (!!!)

Should I avoid starting an anim by duplicating another one? (what I did for at least 50% of my animations but I didn’t see how it could be an issue)

I hope not :frowning:

Just run a quick test

1/ Most of my animations were working

2/ Moved all the anims out of the folders (and renamed them)

(of course I made sure to change the names in Defold)

=> they all stopped working :frowning:

Is this something that could be caused by a messy export?

Or is it something wrong with the Spine extension? (as I said earlier, I never experienced such issues with Spine until now… but never created so many anims etc.)

Looks like I (temporarily?) solved the rubiks’s cube by duplicating / renaming / deleting the original anims etc.

Not 100% sure of what I did but all my animations are now working as intended. If you think there is a potential issue with Defold and the Spine extension), I’ll try to provide a clearer explanation / steps to reproduce (in case you’d want to investigate).

But for now it seems to be ok for me… (until I find out that it’s not… fingers crossed)

Happy to hear that you were able to solve it! I can’t say for sure if this is a problem with the extension or not. I think someone else should have encountered something similar by now.

1 Like