Build error from unknown source (SOLVED)

Hihi, i have very recently deleted an old messy atlas, made sure to check and change everything that used it, and the project works fine if i run it trough the editor, no errors or missing sprites

But if i try to bundle it, i get this error
Unknown source
“Resource ‘build/default/thingies/sprites/images/ATLAS/thingi.a.texturesetc’ is not created”

the folder it manages to create is empty, and i have no idea what or where to look to fix this (saw similar issues on other posts but couldnt find an answer)

Close Defold and delete the project ‘build’ folder. Open Defold and try again. That usually fixes this sort of issue.

tried doing so, didnt seem to fix the issue, ended up making an empty atlas in the same spot with the same name (tried before but made a small typo in the name) and now it bundles properly, not the smoothest fix but its good enough for now lol

thankies anyways :3

Bundling is stricter than normal building, so if you have some object or component with an invalid property (like a sprite pointing to an atlas that doesn’t exist), it’ll throw an error even if it’s not used anywhere in the game. Try searching your project files for “thingi.atlas”.

1 Like

oh gosh you are right!! didnt even know i could search the project files like that

yeah i missed 1 usage of it on an object, that was causing the issue