Build apk file but not run on Android simulators (SOLVED)

I’m trying to build apk file while looking at the official Defold Android development page. I can create an Apk file from the Project tab → Bundle → Android…, but when I open it with an emulator (Nox or BlueStacks), nothing comes out or it is forcibly terminated. I tried both debug builds and builds using Keystore…
I have no real android device.
I tried to build HTML5 is succeed.

I found report Defold games are crashed on Nox player, but it is 2016. still there?
If you have any idea what is my mistake, please let me know …

This is my first build so I’m noob about Android things like apk, keytool.
I used Google Translate. if you can’t understand meaning, tell me.

I would recommend that you get the device log from the emulator. It will likely tell us why it is crashing.

There is an Android tool called adb which you can use to read logs on device or emulator.

Oh, thank you!!! It works.

There was a typo about Admob ID. I’m an idiot.

These pages work for me about path connections to adb and nox_adb in Windows.
I write it for those who face the same troubles in the future.
It’s not an English page, but the video should be useful.

thanks again.

1 Like