Build and Launch gets held up at waiting for connection

#1

I am trying to do a build and launch but when ever I do it pops up with the screen at stays at waiting for connection … I am getting a message that pops up in the console about every 30 seconds .

WARNING:DLIB: Failed to send announce message (-22)

I have taken down my firewall and tried. Is there any way to run this locally or fix this problem?

Thanks! I am new to Defold starting today so I am trying to learn it so thanks for any help.

0 Likes

#2

What OS and OS version are you running?

0 Likes

#3

I am running windows 10

0 Likes

#4

Hey folks,

Has there been a solution for this problem?

0 Likes

#5

@Jongwoo_Kim Are you also experiencing this? Which OS? Windows 10? And what kind of setup do you have in terms of network, connected devices and so on?

0 Likes

#6

I’m running windows 10 on a laptop, connected to a home network by wifi. By connected devices do you mean what other devices are connected to the same network?

0 Likes

#7

The “Failed to send announce message” stems from an issue with SSDP (Simple Service Discovery Protocol) which we use to announce and detect nearby devices to build and launch to. @Andreas_Tadic is the expert on this and should be able to provide more information, but he’s on x-mas vacation. There is some kind of issue with your network or something disturbing SSDP from working as expected.

0 Likes

#8

Is there any way to disable the device detection? I only need to deploy to my local machine.

0 Likes

#9

Not even deploy. It’d be nice to be able to test my code in any way.

0 Likes

#10

Could you try and disable the wifi connection on your computer and try again?

0 Likes

#11

I’m having the same problem when I tried to build and run the Runner test project.
I’m operating on the same system, Windows 10, MSI laptop connected to a WiFi.
When I tried to turn the WiFi it doesn’t work, same when rebooting the WiFi (same error message).

0 Likes

#12

Same for me. Windows 10, Defold Version 1.2.73.
Disabling WiFi does not help.

Does anyone have feedback for this case?

1 Like

#13

Funny, found a solution a moment after posting. Running Defold as and admin user solved an issue.

The hint for me was HTML build failing with info about file access denied (for file from project branch on my disk).

Maybe interesting for dev team as it happened for the empty project. So editor thinks that created something that has no right to create. Or maybe creates as and admin user and tries to read as a standard user ?

1 Like

#14

I went into [Network and Sharing Center->Change Adapter Settings] on Windows 7 and disabled all of the devices except for my main internet one. I had virtual devices from TeamViewer VPN and Virtual Box. After disabling all of those extra devices, the message stopped appearing in the console.

1 Like

#15

Yes!
It worked for me. I found a Bluetooth network adapter except the ethernet adapter. So I disabled the Bluetooth network adapter and now I don´t get any errors.

Thx Sofi!

1 Like