Bob help / docs update


I’ve tried my hand at setting up a very basic bob script. All I need is to bundle to all PC platforms, as this would save time over doing it manually in the editor and waiting in between each platform to kick off the next build.

Generally speaking, I think the documentation page needs an update. It’s a decent start, but there seems to be a fair bit of assumed knowledge. This post in particular really highlighted this to me.

Onto my question and where I got stuck. I’m on Windows 10 and both Defold & bob are 1.2.176. I’ve placed bob.jar and my test batch file in the same directory as game.project. Batch file contents:

java -jar bob.jar --archive --platform x86_64-win32 distclean build bundle

This goes through the % progress but gives me the error: Warning: Failed to clean up temp directory
A ‘default’ folder is created in the build folder, but other than that nothing else. If I run my batch file as admin, I get the error Error: Unable to access jarfile bob.jar instead.

Any thoughts? Couldn’t find any answers on the forum though others seem to have had the same issue. :thinking:



A small note that a warning is not an error.


Not entirely sure what this is, but my guess is that you paused the execution in the windows console?

Here’s the command line I would start with:

$ java -jar bob.jar --platform=x86_64-win32 clean build --archive bundle --bo bundle_win32 --variant debug --with-symbols

And, here’s the brief explanation of what each thing does:
--platform=x86_64-win32 - selects which platform to build/bundle for
clean - removes all previously built content
build - builds all content
--archive - archives the built content
bundle - bundles the content into an app
--bo bundle_win32 - bundles the content into an app (in the folder bundle_win32)
--variant debug - selects debug mode (default is release, with no logging output)
-with-symbols - outputs debug symbols (only for NE builds)

1 Like


We accept pull requests:

What are you referring to specifically? The --resolve requiring email and auth? I do not believe that is required anymore actually.

This happens on Windows only. It tells you that a temporary folder used during the build wasn’t deleted. We should probably remove the warning as it has no real consequence for the user.

Are you sure? There should be an .exe etc, same as when bundling from the editor.

1 Like



I added that to prevent cmd from shutting down as soon as execution was completed, so I could copy the error, uh, I mean warning message. :grin:

Thanks - this works! This gives me something to play with, also appreciate the explanations.



Yes. I was getting a 400 error like Pkeod in his thread, but can’t reproduce it right now when adding resolve back into my test.

Ah, it must be a red herring then!

I’m pretty sure. This is what I see:


And inside default:



Since you didn’t specify an output folder, it will output it in the build/default/projectname

What if you look into that folder? Is there anything there?

You’re using Explorer, what if you search for a “.exe”?



Yeah, there is. D’oh. :expressionless:

1 Like


Trying to experiment with texture compression to see how it affects build size and bundling time. I suspect I’m doing something wrong because build times are similar and the output is identical in terms of file size. Maybe I’m misunderstanding but I’d expect that turning texture compression off would increase file size.

This is what I tried:

java -jar bob.jar --platform=x86_64-win32 --tc false clean build --archive bundle --bo bundle_win64_nocomp
java -jar bob.jar --platform=x86_64-win32 --tc true clean build --archive bundle --bo bundle_win64_comp



How have you setup your texture profiles?

Also, to see the build report, you can add:

–brhtml buildreport.html

1 Like


Texture profiles are using the builtin.

Build reports imply that the parameter in bob is working:


But the file size is identical for both:




It depends on the texture profile settings. Does it actually compress on Windows?



Since we currently don’t support other compression than WebP for Windows, the “default” option that you currently use won’t compress anything.

To cut down on bundle size, you probably want to use WebP compression.

(We have planned to do work in this area soon (i.e. in the next few months))