Win10 game.project is blank

#1

I’ve just fresh installed the defold. I’m newbie on the editor but i think the issue is not my fault. I was following lectures from youtube and there is some options appears on “game.project” file when i open the file as a text i can see some attributes, but normally blank!

Note: OS -> Win10 - 64 Bit
The latest version of the Defold, which is prefer download on official website

1 Like

#2

Does the project build and run or do you get an error?

Does anyone else using Windows 10 have this problem?

0 Likes

#3

It’s fresh Project, just clicked new empty Project so no build error. Also i have MacBook Air i tried with it and also its same. Am i missing something or its really bug?

0 Likes

#4

And you get this when you double click on game.project in the editor?

0 Likes

#5

Exactly, while watching tutorial he was getting atttibutes. Win10 & OS X Catalina i am getting same blank screen both os.

0 Likes

#6

I checked now on win10 again this time by creating mobile project,
game.project and game.input_binding, default.gamepads etc are blank.
Source files are opens normally. Console is working properly, i can build project and test i’ve just installed to try defold platform but couldn’t use it. Hopefully you will solve this issue, i really liked design of editor. It’s so simple no too much things focus to 2d but unfortunately i couldn’t use it.

I’ve tried also with tutorial project “side scroller” one. “.script”, “.go”, image formats, and all scripts are okay, build is okay but i couldn’t see game.project and when i open as a text i cannot edit also above files also same, the blanks one.

0 Likes

#7

Until the problem is fixed, you can always open your game.project with a separate text editor (just Wordpad or something) and set the values by hand. It’s not very convenient, but at least you can continue to work.

You can see a list of all the project settings here https://defold.com/manuals/project-settings/.

0 Likes

#8

Can you see if you find anything in the log files?

2 Likes