Unable to run exported builds in manjaro linux (SOLVED)

#1

Hello. I have been using Defold 2.0 for over a year now, half a year on windows and half a year on manjaro linux and I have had a lot of issues with it from the moment i switched to linux. Now i ran into a problem that i can’t fix so i came here to request help. I never had this issue before with my game but now the problem occurs when I try to launch a exported version of my game, I can launch my game just fine in the engine but not outside, outside it just pops up the window and crash within a second. And now a new problem just occurred it would seem I can’t even export my game anymore, please help.

0 Likes

#2

HI! I’m sorry to hear you’re having problems running the game on Linux. We need to know more about your project and any kind of additional information that can help us diagnose the problem. Please start by reading through this:

And provide us with an error report in this thread, or even better on GitHub. Log files are the most important. I’m sure there’s some clue to why the game crashes.

0 Likes

#3

Yes i would like to provide log files but where can i find them on a export?

0 Likes

#4

It’s documented in the link I shared:

0 Likes

#5

Problem solved i had reached the maximum number of resources that was set in the game.project file. Thanks

0 Likes

#6

The only thing i don’t understand is why it wasn’t showing up the error but in the build it did might be a good idea to fix this

0 Likes

#7

Sorry for spamming but here are the logs for the startup in the engine:

INFO:DLIB: Writing log to: ./log.txt
INFO:ENGINE: Loading data from: build/default
INFO:ENGINE: Initialised sound device ‘default’

Registered astar Extension
INFO:DLIB: SSDP: Started on address 192.168.1.9
INFO:DLIB: SSDP: Done on address 192.168.1.9

and the ones on the exported build:

INFO:DLIB: Writing log to: ./log.txt
INFO:ENGINE: Loading data from: dmanif:./game.dmanifest
INFO:ENGINE: Initialised sound device ‘default’

ERROR:RESOURCE: The max number of resources (1024) has been passed, tweak “resource.max_resources” in the config file.
WARNING:RESOURCE: Unable to create resource: /main/main_generated_3.goc
ERROR:GAMEOBJECT: Could not instantiate game object from prototype /main/main_generated_3.goc.
ERROR:GAMEOBJECT: Child not found: /factories
WARNING:RESOURCE: Unable to create resource: /main/main.collectionc

both of these are with the same game… so i dont see why this occurs.

0 Likes

#8

Not sure why it is different between editor build and exported build.

Did you increase this setting in game.project? https://defold.com/manuals/project-settings/#max-instances

0 Likes

#9

Yes i Increased it and it fixed my issue. so here’s what i get from this i think in the engine it loads a bit less of resources and when builded it loads a bit more of them so maybe you could try making a project just under the max resources limit and building it to see if that’s the issue. try it on different OS to make sure if it’s not a global problem and not linux exclusive.

1 Like