Tilemap, can't select multiple tiles at once


I am following the tutorial “War Battles”, and at the very beginning, when creating the tilemap, the tutorial says that you can create a brush of many tiles by pressing the SHIFT and dragging on the tiles while editing the brush. This is in the section “Draw the game map”, in point 8.

You can hold Shift, then click and drag to make a selection on the current layer. The selection then becomes your new brush. This is a useful way to paint with a brush consisting of multiple tiles.

This appears not to work, at least on osx and with the editor version 1.2.137.

Either the tutorial is wrong or there is a bug.


It what way does it not work? Do you get a brush the correct size but it’s empty?

I am getting a brush of a single tile. It doesn’t seem like I am allowed to select multiple tiles at all. I would expect to see some kind of box while shift-dragging, but it doesn’t show up.

Are you trying to select multiple tiles while painting the tile map or while selecting a tile from the tile source (e.g. hitting space and selecting which tile to use)? Selecting multiple tiles is only supported when painting, not when selecting what tile to paint with.


Aha! That’s it :slight_smile:
This is good enough, thanks!


Great :smiley:

Yeah, we probably need to improve the instructions. Ping @sicher We had the same question a while back: Shift-select multiple tiles doesn't work (SOLVED)


Not being able to select multiple tiles in the tile source is a huge decrease in productivity…
If you guys implemented that, it would be great for your users.


If you have combinations of tiles that you use frequently you can draw them on the tilemap and then select them as a group.


Thank you for your feedback.

The technique you mentioned works, but it’s still very slow for certain tilesets… (such as in the defold tutorial I was following: “War Battles”).

I am sure many future Defold users will find this thread when they google for “can’t select multiple tiles in defold tilesets”. Please let us know if the Defold team plans on implementing this feature.



I agree. It is some times just too tiring to paint a large group of tiles one by one especially when working on large tilesets. :face_with_thermometer:


Yes, at first I was trying to select more of the tiles in the brush select space, trying holding shift or ctrl, anything that is intuitive to select more than one tile, but none of them worked so I ended up with @britzl’s solution :confused: it’s not intuitive and if it could be implemented we should have have a ticket for this feature.

Can I create that one?

@vlaaad you did some improvements to the tilemap editor recently. How difficult would it be to add multi tile selection to the palette?

Definitely possible, and I agree we should have this behavior, I miss it too


I’ve created this issue: https://github.com/defold/editor2-issues/issues/2560
If you guys have other way of adding tickets, please correct it :wink:


Hello everyone :slight_smile:
Has the multiple selection for painting been implemented?

No, the issue linked above is still open.


Bumping up, people on Discord were asking about it, I would like to have such feature too! :smiley:

Yes, sorry, not implemented yet. What you can do now though is to select multiple tiles in the tilemap itself and use that as a brush. It helps quite a lot when needing to duplicate groups of tiles on the tilemap.

1 Like