Testing locally fails third build onwards with v1.2.173 and v1.2.174

#1

I get a “Launching Local dmengine failed” error almost every time I try to build locally. It consistently happens every THIRD build, for some reason, and every build thereafter; closing down the build window always allows two fresh builds before failing.

It started happening after updating Defold to 1.2.173.

The project I’m testing is minimal; one collection with a script attached to it and one module.

Update: I’ve now tried the following things to resolve this;

  • Restart Defold
  • Restart wifi
  • Restart the Mac

A video of the issue using an unedited blank project:

Is it time to revert to an earlier version of Defold? :cry:

1 Like

#2

After downgrading I can confirm v1.2.172 doesn’t have this issue.

0 Likes

#3

@JCash could this somehow be related to the socket changes (dmSocket)?

1 Like

#4

It’s of course what first comes to mind. However, I don’t recall any obvious changes that would produce this type of behavior. We’ll have to look into this.

2 Likes

DefVideoAds (plugin for Unity ADS). Video ADS native extension
#5

Issue: https://github.com/defold/defold/issues/5215

1 Like

Defold 1.2.173 has been released
#6

I’ve started using the latest v1.2.174 build for the iOS 14 compatibility fixes, which all seem to work great. This issue remains, however, so I was wondering if I can help troubleshoot this, since it’s slowing down testing a bit. Although sometimes I get a feeling for when the third launch is coming, force close the game and feel like a winner. :metal:

0 Likes

#7

I close my game in between each of my builds (using Escape), and I still get this issue. The game is closed as far as I can tell, but still running in task manager. If I kill it there, I can build again. This is Win 10, 1.2.173.

0 Likes

#8

@JCash has started investigating this issue, but we have no solid leads yet. Changes have been made to the socket code so it’s like there somewhere we have a problem.

0 Likes

#9

I have found the issue, and implemented a fix for it.
It was an issue with app flow, not about socket changes.

But now I’m stuck on a (seemingly unrelated) test failing.
Expect a fix for 1.2.175 though.

3 Likes

#10

Is the blessed v1.2.175 scheduled for beta release anytime soon? I look forward to a day of gamedev with no pesky little popups when I forget to close down the game.

0 Likes

#11

On Monday.

2 Likes