System locks up when editor starts - Fedora 30

#1

I was going through the side scroller tutorial and, when it gets to the part where you add the bonus_star, as soon as the editor opens the system locks. I have to do a hard reboot. Has anyone else have anything like this?

0 Likes

#2

Ping @vlaaad and @markus.gustavsson!

0 Likes

#3

I just tried side scroller tutorial and it worked fine. I’m on linux, but not on a Fedora. Does system crashes when you open any game object? It might be a driver issue. In that case you can try setting environment variable before starting editor, as described in FAQ.

Maybe you have some errors in logs (Help → Show Logs)?

3 Likes

#4

I just tried it on Fedora, but in a virtual machine, Windows 10 host. Works fine for me.
Please supply logs if you can (see Vlads post)

2 Likes

#5

Based on a similar problem someone else was having, I attempted to install the Nvidia drivers. But my laptop is slightly older and the amount of effort involved to even attempt to do this was cost prohibitive. I did try the trick in the FAQ but that didn’t make a difference. As a test, I ran through some other tutorials and every time I tried to open any game object, new or pre-existing, it always locked the display. I can ssh in and reboot, though.

Just for kicks, I’m going to try running the Win version in wine and see what happens there. If that doesn’t work then it’s VirtualBox, here we come.

Thanks for the assistance, though.

2 Likes

#6

Hello. Sorry for the late reply.
I don’t know exactly what could cause this and I am sad to say that we cannot spend any more time on this issue right now. I hope that you will find a workaround so that you can at least use Defold even if it is not natively on your preferred machine.

0 Likes

#7

I understand completely. Time to see how it does under Wine (or Crossover). If that doesn’t work? Win10 under a virtual setup. And if THAT doesn’t work, I’ll be on the lookout for a cheap dedicated WinXX system. LOL

FWIW, thank you for giving it a shot. And if I ever do find out what the frell is going on with my Linux setup, I’ll pass on all the info I can.

Yours,
Joe

3 Likes