Spine. Inherit Rotation (DEF-2232)

#1

Hi.
*I’m not sure this is a bug or not
And maybe you already know about it.

If we disable Inherit Rotation in bone options we get strange thing

In spine:

In defold:

0 Likes

#2

Hmm, I’m not sure what the expected behaviour is. @sicher, @Mathias_Westerdahl, @sven, do you know?

0 Likes

#3

I bet we don’t support Inherit Rotation = false yet. I know we support Inherit Scale = false.

1 Like

#4

The Spine-wizard (@sven) confirms that we do not support inherit rotation = false.

1 Like

#5

I’ve added a ticket for this: DEF-2232 Am I correct in assuming that this isn’t a blocker?

1 Like

#6

As said my animator, this is a very useful option for the animation of walking (for example). If this option appears, it will be great :slight_smile:

But we try work with out it.

1 Like

#7

Interesting! If you have any links to read up on the topic, it might be useful :slight_smile: Personally, in more familiar with a “sliding window/frame” which iirc doesn’t involve rotation?

0 Likes

#8

Sorry to answer that old topic. But it seems that Inherit Scale = false no longer works.

I don’t know if the spine syntax has changed. But the statement
{ "name": "head", "parent": "body", "y": 330, "transform": "noScale" } seems to have no effect.

0 Likes

#9

I guess you are using a very recent Spine version, and Spine has a tendency of changing/breaking the json format on even minor updates. In previous Spine JSON versions the “Inherit Scale” option is saved as the field “inheritScale” of bones… You could try replacing "transform": "noScale" with "inheritScale": false as a workaround, just to see if it works. Otherwise I would recommend downgrading Spine to an older version.

3 Likes

#10

Thanks, that was a lifesaver.

Hopefully more Spine 3 features will be supported soon.

0 Likes