[Solved] Graphics error causing crash on Windows after upgrading to v1.60

I have been evaluating Defold on the side since the past few months. I was mostly running the Defold templates to learn how to structure the project.

This weekend I upgraded to v1.60 and tried to make a new project from scratch. Everytime I try to build the project on my Windows 10 laptop the build crashes with a graphics error listed below.

ERROR:GRAPHICS: dmGraphics::OpenGLFlip(1509): gl error 1280: invalid enumerant

To cross check, I loaded the Defold platformer template which I remember running fine previously, it gives the same error.

However, the HTML5 build runs successfully! Seems like a desktop build issue.

Laptop specs: Intel(R) Core™ i5-5200U CPU @ 2.20GHz 2.19 GHz
iGPU: Intel HD Graphics 5500 (doesn’t support Vulkan)
graphics driver: version
(this is the latest version according to Intel driver and support assistant)
Windows version: Windows 10 version 22H2

I have tried to solve the issue by upgrading the integrated graphics driver after referring to previous posts about opengl error but no success! Hopefully the good folks here could point me in the right direction.

PS: Attaching screenshots of the error in Defold console and the driver version of iGPU

Hmm, @jhonny.goransson or @JCash any ideas?

I have no good idea.

Is that driver really the latest there is? It’s from 2020? :thinking:

Update: Problem solved. Hopefully this would be of help for others facing a similar problem when using old hardware.

The driver mentioned above is the latest driver for the iGPU, the solution was found after disabling some 3D options in the “Intel HD Graphics Control Panel”.
To be specific:
Disabling - Application Optimal Mode
Turning off - Conservative Morphological Anti-Aliasing

I do not know the exact reason why this solved the “gl error 1280: invalid enumerant” error so I’m attaching the screenshot of the settings page.