So I just played Look, Your Loot! on Oculus Quest 2

#1

I mean, I ran it. Turns out the Quest is basically just a phone glued to your face and accepts apk files. I chose my favourite Defold game to experiment and it worked!

Well, kind of. The game was projected into the virtual space in front of me (I could go right to it to examine the lovely main menu graphics in detail), without any graphical issues I could see. I wanted to record a video, but it went dark just as the game launched, citing lack of permissions from the app’s creator. I should be able to set up a stream it to my computer and record it that way later if you’re interested.

At first I thought I couldn’t control the game, but I think there’s only some issue with screen coordinates converted from the VR space, since after clicking frantically everywhere, I managed to click through to the puzzle selection screen, return back to main menu by mashing one of the controller buttons and then open the collection. The drag-to-scroll mechanism in the collection worked flawlessly in VR. Sadly, I haven’t been able to find where to click to launch the game proper.

Oh, and I couldn’t exit the game no matter what, until I turned the whole headset off and on again.

So anyway, official Oculus Quest support when? =D

I guess I’ll make a test app in the near future to see what else I can do with this, what’s the deal with action coordiantes, which controller inputs I can use etc. I may not be able to make in run in a true immersive VR fashion, but it would still be cool to have something I made running on it. Worst case scenario I do a factory reset if I mess things up too badly. And at any rate, since I got the Quest, I didn’t touch Defold at all, so this might be a way back for me.

7 Likes

#2

Wow! Interesting :smiley:
I was testing my game on Android smartwatches year or so ago and it was even playable, though very hard :smiley:
Interesting what you could see in Oculus when you for example upload some 3D Defold game or orthographic game but with world rendered even “out of” screen. Share your experience, I will be waiting! :wink:

1 Like

#3

Well, I did some testing and unfortunately the amount of awesome I’ll be able to do with it is severely limited.

The big one is that I haven’t found a way to display the app in anything but a virtual window. Setting the horizontal resolution to a very high value only made the graphics appear squished, so it seems there’s some reasonable upper bound for that. I messed around with the render script, but I don’t think that’s going to help. Setting the app as fullscreen and/or immersive mode also did nothing.

Unsurprisingly I couldn’t get the head tracking data, nor controller position. I was thinking that taping one controller to the headset with a button pressed button would be a way to calculate the direction the headset is facing from action.x / action.y, but given that I can’t move the virtual screen, it would be pointless.

As for controllers, several of the buttons are recognised as the left mouse button. I could get the “back” input by pressing two specific buttons at the same time. Not extremely useful, but I suppose I could use it as a way to close the application rather than my current solution which kills it after 60 seconds from launch. I got nothing from the joysticks. At least the “clicks” return some screen position values as well as multitouch.

So… as it stands, I suppose I could make some sort of simple shooting gallery game with this. And I guess I will, just to be able to say I made a game for the Quest.

That said, two years ago I actually managed to get one of the UDGJ#1 entries working in VR using a phone, GearVR and a bunch of third-party software. I think it should be possible to repeat that now that I have an actual VR headset. The game I’m working on right now would actually benefit from this kind of janky setup.

Oh, and I think I’ve figured out a way to capture some footage of my experiments, but I’ve also figured out that you can play Doom 3 on the Quest, so I’m going to do that instead and share some videos tomorrow =P

0 Likes

#4

Eh, I thought I could bypass the screen capture restrictions by streaming using a sideloader app, but either something changed, or I did something wrong, but I only got black screen as soon as my testing application started, so no screenshots or video is coming.

For now I’ll shelve further testing. I want to explore some ways of streaming non-VR games to the headset in the future so I’ll post an update then, but it will take quite some time, effort and possibly a relatively expensive thrid party app, so it will have to wait for now.

0 Likes