Slime Defense - Idle Tower Defense

#21

Thanks! I’ll take a quick look tomorrow

2 Likes

#22

Could it be that the slime and background are just on the same Z-depth? This could explain why it only happens sometimes/on some devices.

3 Likes

#23

Alright, I’ve looked a bit at the code you sent me and at least the disappearing slimes should be easy to fix. You set the position.z to -2000 in the monster.script, which means that they get culled. Why it works for other devices I have no idea, it shouldn’t work at all but somehow it does :man_shrugging: I set it to -1 instead and it seems to work, so you could try that. I built it with 1.2.158.

For the buggy text I’m not sure, I’m guessing it’s a precision issue but I don’t have a solution yet. I get similar issues if I use the multisampled + multilayered distance field font shader (font-df-ms) in a project that just renders fonts, whereas the standard df font seems to work fine…

2 Likes

#24

Bug report
Installed it today, and the game’s not running. It sticks on the loading screen for a while, and then closes automatically. So sad I can’t play it. :slightly_frowning_face:

1 Like

#25

Huh, okay! It’s weird how that works in most devices and some not. I will give that a try!
Thank you!

0 Likes

#26

Sorry about that! That seems to happen to some people, but I know a workaround.

  • Load the game without internet conecction
  • When you see the Internet connection needed pop-up, turn internet back on
  • Tap of retry in-game
0 Likes

#27

I tried it but it doesn’t work :sob:

0 Likes

#28

The need to be online to play is annoying, plus the game will be dead forever if you ever decide to stop supporting it.

Anyway, here’s a few notes from a couple of days’ (obsessive) playing:

  • Since the research menu only holds 10 items, it can ger packed with stuff I don’t want to buy pretty fast (such as castle health / peasants while everything dies to my first two towers). It would be best if it didn’t offer more expensive versions of upgrades you haven’t bought yet. I’ve tried getting them out of turn, but it doesn’t do anything special - the lower upgrade is applied first even if you pay for the more expensive one.

  • The keys / fragments display in the top right corner could be more visible. I’ve completely missed it when either of these became unlocked (for a while I thought keys could only be bought).

  • At the time turbo mode is introduced, it’s not that necessary while gems are shown to be of utmost importance. I think the player should get one freebie to try it out. As it is now I still haven’t used it even though it’s likely worth it, as the gem feels more valuable.

  • The next/previous round buttons disappear and reappear too abruptly. I’m usually watching to top of the screen and it registers as annoying flicker. I think having them fade out would be better. Same goes for the ability buttons.

  • If an ability button is over a tower, both get pressed at the same time, opening the tower management interface and preventing you from triggering additional abilities.

  • In between rounds in dungeon mode the abilities recharge, even though they are invisible. It often makes me wait until the time runs out to make sure they are charged, but since I can’t see the progress, I have to wait until the time runs out to be sure.

  • Unused peasants should work in the castle by default.

  • The chest opening animation gets annoying pretty fast.

  • When upgrading a tower, additional upgrades after the first should perhaps be done with just a single tap.

  • Sometimes I want to know how much gold I’m making for beating the currect wave, but it flashes way too fast and I sometimes miss it even when looking for it.

I’ll let you know if I think of anything else.

Edit:

  • Some bonuses/percentages are a bit confusing, for example the Fel rune says “…chance to deal 52% damage”. That sounds like it might cut your damage in half.

  • Clicking the “extra gold” powerup should show how much time is left.

  • Speaking of which, it seems the powerup is stuck on my screen after it ran out.

  • I’m usually combining runes in bulk, so it’s annoying that the menu changes to the upgraded version when I still have a couple of low-level runes of the same type I want to combine.

  • One of my towers has so much poison damage that the number it overlaps with the text “Poison damage”.

0 Likes

#29

Both Autocasting and Overseer upgrade tutorials bugged out. Attached is a screen showing the the game as it froze after buying the former (just after the princess said to meet her on the battlefield).

Additionally, the encyclopedia entry for autocasting says the icon is at the bottom right.

And autocasting doesn’t seem to work, but it might be just that the slimes die to my towers too quickly?

1 Like

#30

I will reply to you in a PM!

1 Like

#31

Are you on Android? You can help out by checking your logcat, to look for messages.

1 Like

#32

The link didn’t work. This did though :slight_smile: https://play.google.com/store/apps/details?id=com.zeppeln.slimedefenseidle

0 Likes

#33

I should’ve mentioned! The game is getting republished under a publisher. For now, only the Android version is out.

5 Likes