Running bob.jar resolve with --settings doesn't override dependencies (#4594)

#1

I have the following setup:

game.project:

[project]
dependencies = https://github.com/subsoap/defos/archive/v2.4.0.zip,https://github.com/dapetcu21/defold-fmod/archive/v2.1.1.zip,https://github.com/britzl/defnet/archive/3.3.zip,https://github.com/britzl/defold-luasocket/archive/0.11.1.zip,https://github.com/britzl/defold-googleanalytics/archive/1.4.1.zip,https://github.com/subsoap/discordrich/archive/v1.0.4.zip,https://github.com/britzl/defold-richtext/archive/5.10.2.zip,https://github.com/britzl/defold-input/archive/2.4.1.zip

steam.ini:

[project]
dependencies = https://github.com/subsoap/defos/archive/v2.4.0.zip,https://github.com/dapetcu21/defold-fmod/archive/v2.1.1.zip,https://github.com/britzl/defnet/archive/3.3.zip,https://github.com/britzl/defold-luasocket/archive/0.11.1.zip,https://github.com/britzl/defold-googleanalytics/archive/1.4.1.zip,https://github.com/subsoap/discordrich/archive/v1.0.4.zip,https://github.com/britzl/defold-richtext/archive/5.10.2.zip,https://github.com/britzl/defold-input/archive/2.4.1.zip,https://github.com/dapetcu21/steamworks-defold/archive/master.zip

[steam]
app_id = 1016770

The dependency lines are identical save for the extra dependency on Steamworks in steam.ini

Running

bob.jar --email foo@bar.com --auth 12345 --settings steam.ini resolve

on this doesn’t download the Steamworks extension. It looks like it uses the deps from game.project instead of the overwritten ones.

1 Like

#2

The fix should be in 1.2.165

2 Likes

#3

Issue 4594

1 Like