Rive assets filled black color

Steps to reproduce

  1. Add https://github.com/defold/extension-rive/archive/main.zip as a dependency.
  2. Fetch libraries
  3. Change render file to rive.render
  4. Create rivescene file and add your rive file.
  5. Add rivemodel to the main scene, select default animation.
Build time 2021-12-16T14:45:33.859978
Defold channel editor-alpha
Defold editor sha 09da5fbf86f611727c6f533a6078c0d84f6b8da9
Defold engine sha d31d6397a72178541a5ef6e7ef2bed090d828f58
Defold version 1.2.190
GPU Driver 4.6.0 NVIDIA 472.12
Java version 11.0.1+13
OS arch amd64
OS name Windows 10
OS version 10.0

How animation looks in rive app.

How looks my .rivescene in defold

How looks build. Animation plays but fill black color

My .rive file and .rivescene in zip file.
ball.zip (806 Bytes)

Maybe I set up something wrong.
Thanks for any help!

Thanks @bedryck . We saw the issue on GitHub and were discussing it today. We’re looking into it!

1 Like

Thank you a lot for feedback

1 Like

Hi! Thanks for the repo case, I’ve found one issue with the clipping of the strokes that I’ll fix as soon as possible. I haven’t found the issue with the incorrect colors yet, but I expect it to be something simple since it works for most other rive scenes.


Hi, @jhonny.goransson thank you!
I am glad to hear this :blush:


Hi, I’ve made some progress on this:

As you can see, the stroke in the middle isn’t 100% correct, it’s using a blend mode on the layer that we don’t have support for yet. I’ll have to look into that.


Hay, for me looks perfect!) Nicely done @jhonny.goransson

1 Like

I’ve got a similar problem… I can’t even get a “hello world” simple one-color circle to render with any colors.

There’s an issue with the editor preview rendering black which we will solve soon. But a Project-> Build should render in full color.

Thank you, makes perfect sense! I was confused by another bug (I think) that made the animation not be rendered at all in Project->Build, but I worked it around.

I was playing with simple Rive scenes (shapes without animations) and I can notice that Rive models inside Defold viewport are still seen as black only…

Really? Which version of the extension and of Defold are using?

Defold 1.3.1

extension version
https://github.com/defold/extension-rive/archive/main.zip and also https://github.com/defold/extension-rive/archive/refs/tags/0.11.0.zip

Shape is only black in the viewport, when I build that project shape is OK looking.

Yeah, sorry about that, it was fixed some time ago but never merged:
Please use the latest release 0.12.0:


Thank you, it works now!