Remote target crash from PC to iPhone (SOLVED)

Is streaming the application to a remote target from PC (Windows) to Mac/iPhone supposed to work? When I try to do that the app freezes after printing this line:

INFO:ENGINE: Defold Engine 1.6.0 (d9e9c49)

After a while it crashes saying:

FATAL:ENGINE: Unable to load project file: ‘http://<ip…>/build/game.projectc’ (-1)

It works fine when I stream from my Mac to the iPhone or to the PC.

Yes, it is supposed to work. Firewall blocking the connection perhaps?

Yeah, that’s what I thought too. But even after disabling the firewall I get this behaviour. The initial connection between the devices seems to work – the freeze happens shortly after building and running the app.

Is there any way I can debug this myself? I tried to check the iPhone logs, but I didn’t find anything out of the ordinary.

After some investigation by building the engine I found out it freezes at the point where it tries to connect:

*sr = dmSocket::Connect(*socket, address, port);

Anyway, I must have gotten lost in Windows 11’s new fantastic firewall settings UI by only turning off the firewall 1/3 times (apparently you have to turn it off for all network types separately unless you use the old Control Panel).

To still be able to keep the firewall active, I had to allow the OpenJDK Platform binary that’s shipped with Defold through the firewall. It can done by ticking the box to the left here: