Project starts too long on Defold 1.2.165

#1

Hello there!

I have a project, which I’m developing about last 6 months.
Everything was ok until I’ve updated Defold (1.2.165 (6fac6e8)) and Ubuntu (Ubuntu 18.04.4 LTS) to the latest versions.
Now when I run the project it hangs on 10 seconds on start.

I commented out everything from Main Script Init function and added just simple log string.
Now Defold log looks like:

INFO:DLIB: Log server started on port 37779
INFO:ENGINE: Engine service started on port 35007
INFO:ENGINE: Defold Engine 1.2.165 (6fac6e8)
INFO:ENGINE: Loading data from: build/default
INFO:ENGINE: Initialised sound device ‘default’

DEBUG:SCRIPT: HERE 1
WARNING:DLIB: Profiler Engine.Init took 10.171 seconds
INFO:DLIB: SSDP: Started on address 172.16.6.5
INFO:DLIB: SSDP: Started on address 192.168.0.13
INFO:DLIB: SSDP: Done on address 172.16.6.5
INFO:DLIB: SSDP: Done on address 192.168.0.13

The 10 seconds hang is on the line:
INFO:ENGINE: Loading data from: build/default

I don’t have any payload in Main, only 1 image in Atlas, but if I removes it nothing changed.
I tried to reinstall Defold and this didn’t help. Also I tried to build my project under Mac OS with latest Defold and everything was ok.

Why this happens? How can I get detailed logs? How to fix it?

Thanks

0 Likes

#2

Are you saying that if you go back to 1.2.164 it works again? Old versions:

0 Likes

#3

I installed Defold 1.2.164 (2be2687) right now, and yes, everything works as expected.
Another thing I’ve got sight of that in Defold 1.2.165 (6fac6e8) the executable file looks like library and has a property shared library (application/x-sharedlib). I don’t know if this is important.
I will use old version of Defold for now, please, notify me, when you’ll fix the problem.
Thanks

0 Likes

#4

So there is no delay when starting your game in 1.2.164 but you get a very noticeable delay in 1.2.165? On Ubuntu? And even in an empty project?

0 Likes

#5

Yes, on latest Ubuntu I have a very noticeable delay in 1.2.165 even in an empty project.
On Defold 1.2.164 its gone.

1 Like

#6

I got this problem today after Ubuntu security update. Downgrading the Update was impossible. So I reinstalled Ubuntu 18.04 LTS from scratch and disabled the Updates.
Now I can work with Defold like before

1 Like

#7

What did the security update contain?

When you build and run from the editor the editor will try to connect to the running game on localhost with a random port. Maybe there is some security thing blocking or slowing down this process?

0 Likes

#8

I don’t know. The update was very small, a few KB. I also ran Defold with sudo, but nothing changed until Ubuntu was installed from scratch and Updates disabled.

0 Likes