When bundling android (165 version), the following error appears:
Defold 1.2.165 has been released
Which dependencies do you have in your project?
I use the following dependencies :
Wow, that is a long list! Some recommendations:
Never depend on the master branch. Always depend on a specific release:
If you depend on the master branch you will always use the latest version of a dependency. This could introduce subtle bugs or breaking changes into your game. If you depend on a specific version you will be in control over if and when to update to a new version.
Gradle and deprecated base extensions
These are no longer needed. Defold 1.2.165 introduced support for Gradle. Gradle will resolve transitive dependencies if the extension contains a build.gradle file. For instance in Firebase Analytics:
I would recommend that you update to the latest Facebook extension as that version supports Gradle:
There may be other things to change as well, but please start with the above changes and report back here with the results.
Thank you very much, I will try!
@alexandr.gil did you manage to build your project when you updated your dependencies?
Yes! This works great, thanks!
I was just about to post a question here asking how to find specific versions of releases to achieve the above, but managed to find it myself. The answer is to navigate to the “Releases” portion of the github page. For example for DefSave: https://github.com/subsoap/defsave/releases
Currently when I try to bundle my game I get the same error.
I use these dependencies :
My defold version : 1.2.166
Any ideas on what could cause this error?
You want a version 1.1.0 or above. 1.1.0 added support for Gradle builds. And there has been several new versions since (adding leaderboards, achievements and events):