Orthographic - strange GUI stencil behaviour

In my game, I use a GUI node to block parts of the screen that I don’t want to be visible (think “black bars”). I have a parent node called “view” which I scale and position to match the portion of the screen I want visible. The “view” node has a child called “block” which is simply a huge node that does the blocking. For the parent node (“view”) I set Clipping Mode to Stencil and then tick Clipping Inverted. This produces the result I expect.

Using Orthographic, when I maximise my window, the lower left portion of my screen is not covered by the blocker GUI. If I disable the stencil, then I can verify that the nodes are where they are supposed to be. Furthermore, if I use a default render script, the stenciling works as intended.

I attach a video to explain the issue here (sound on because I provide some beautiful narration):

Here is the repro from the video:
gui_stencil_repro.zip (219.4 KB)

Ping @britzl for obvious reasons. I’ve posted this here in case someone else might have some input, but I am also happy to open an issue on Orthographic if you think that is more appropriate.


I’ve got a temporary workaround in place (a PNG with a hole in the middle, completely circumnavigating the stencil functionality), but I’m still curious about what’s causing this.


Hi Alex,
you just gave me the solution to get rid of a stencil that has vexed me - great idea, thank you!