Minimum supported iOS version will be increased to 8.0


#1

Starting March 2019, all iOS apps submitted to the App Store will need to be built with the iOS 12.1 SDK or later. We are currently upgrading our build pipeline to use iOS 12.1 SDK and expect to finish the work before the release of Defold 1.2.147. The minimum iOS version supported by iOS SDK 12.1 is 8.0 which means that we will have to increase the minimum supported iOS version from 6.0 to 8.0. This should have very limited impact, but it will mean that some really old Apple devices that aren’t able to run iOS 8.0 will no longer be able to run Defold games.


#3

This is a reminder that this change will happen on Monday the 18th of February when Defold 1.2.147 is released.

I would like to send out an extra reminder to anyone using a custom info.plist file for iOS. Starting on Monday you need to make sure to upgrade your plist file so that the MinimumOSVersion key and others reflect this change. Refer to the info.plist file in builtins/manifests/ios/ for the most recent values.