Mapping Gamepad, adding not conventional gamepads to Defold


#21

strange… i have osx too… but see no new files as you can see on my screenshot above.
anyway, thank you very much for giving me name of file generated by gdc “default.gamepads” - i’ll try to find it :slight_smile:


#22

Odd, here’s what it looks like for me:


#23

wow, thank you :slight_smile: strange, but I don’t have any… my be because you have only Bye at the end and I some strokes about trunkating history files. I’ll try to find out my local problem


#24

Would this work with a amazon fire tv remote too?


#25

I’m not familiar with Amazon Fire TV remote, but I don’t think it would register as a traditional gamepad. Do you have any link with information how it works that you could share?

I found this, is it correct? https://play.google.com/store/apps/details?id=com.amazon.storm.lightning.client.aosp&hl=en

It might be possible for us to catch some events that we currently aren’t listening to on Android.

edit: Ok, found some more detailed information here: https://developer.amazon.com/docs/fire-tv/remote-input.html

It looks like something we could/should listen to on Android devices. I’ll add an issue for it, but I can’t promise when it will be prioritised.

edit2: Issue added: DEF-3123


#26

I’m trying to map a PlayStation 2 controller to use with Defold using the gdc mini-tool but get the same error as some others:

image

Windows recognises the gamepad and various testing programs I tried also function as expected. I’m considering getting a more modern controller but suspect I might get the same issue.

Any ideas?


#27

Hmm, I’m not very familiar with our gdc tool. @sven or @jhonny.goransson might know more?


#28

@Ben_James
Could you try the Joystick Tester app I linked in this reply: Mapping Gamepad, adding not conventional gamepads to Defold

Does it show up?


#29

Yes, I already tried that - it works as expected.


#30

Damn, alright. :confused:
I need to find a PS2 controller and debug here, I don’t really have any other idea what could go wrong. Are you using a PS2->USB adapter btw?


#31

Yes I’m using a PS2->USB adapter. Have also tried different USB ports and another computer but get the same error.