Output Stream is closed - crash on 64bit linux during build when USB mouse conencted


When I do a build of almost empty project on 64 bit Linux, Defold version 1.2.82 see a major problem with editor:

  1. In console I start receiving errors (new ones appearing like every second):
    INFO:CRASH: Successfully wrote Crashdump to file: /home/michal/.Defold/_crash
  2. Window with my project builded content is stuck, in a moment I get a system message that it is not responding
  3. dmengine process is consuming CPU relatively high
  4. After I run a Defold again in the error log I see Output Stream is closed

Screenshot of error log

Crash binary log

Log mentioned in Error log message

Project is correctly bild on the same version of Defold on my VM with 32 bit Linux.
Also when I try totally empty Defolf project is build with no crash on Linux 64 bit - issues start after adding even simple elements to project.

Any idea where to start investigation?

@jakob.pogulis do you have any ideas or suggestions?

have the same problem. It happens only when i connect mouse. If i use touchpad everything ok.

1 Like

I’ve tried removing mouse receiver from USB… and I can do to the build! I put it back and run the build - it crashes. Tested on different projects.

Good to know what causes it, would be even better to still work with mouse :slight_smile:

Looks like related to:

In the meantime I see it works with the other mouse (wireless, USB dongle too)