I try to use NotoSansCJK font, but I get an error


#1

If I specify a font as a NotoSansCJKkr.otf font, the font preview page displays error.
Render error: -blabla.font: Failed to generate bitmap from Font. No glyph size information. Incompatible font format?

If I use a font with a render error, it working in English font but not working Korean font.

Noto fonts as well as other Korean .otf fonts have the same error. Korean .ttf fonts do not get an error, but NotoSansCJK is not available as a .ttf.

I tried to search the forum for errors, but I could not find an appropriate answer.

How can I solve the problem?


#2

There seems to be some kind of issue with those .otf fonts. When I try to convert them to .ttf format I get an error or a very small .ttf file back. Not really sure what the problem is to be honest.


#3

What would it take to support otf?


#4

I do not think there will be a problem with the NotoSansCJK font.


#5

We do support Open Type (https://www.defold.com/manuals/font/) but it seems like there is something with this font that our pipeline (and some online converters) doesn’t like.