Facebook Instant debug bundle runs very slowly (SOLVED)

#1

Bundling as debug to Facebook Instant (and probably pure HTML5 too) runs very slowly, around 10fps on my device. Bundling as release runs at 60fps.

11

Sample project:
EmptyFacebookInstantProject.zip (2.6 MB)

0 Likes

#2

Just add “–verify-graphics-calls=false” in game.project -> HTML5 -> Engine Arguments

2 Likes

#3

Awesome tip!

Thanks

0 Likes

#4

:flushed:

After a bit of trial and error, I figured out that this is the correct formatting:
17

10fps to 60fps on device. This black magic should be clearly documented, as it stops testing. I spent hours troubleshooting it.

Thanks so much @AGulev, I’m back on track!

1 Like

#5

It has been mentioned numerous times here on the forum. I’ll add a note in the relevant manuals as well.

The problem is on Chrome (probably Chromium even) where WebGL validation is notoriously slow. We only do this for debug builds. In release we do not validate/verify/error check all graphics calls. On Firefox and Safari it should always be fast.

2 Likes

#6

You should have gotten a hint from the developer console? Didn’t you see any logs there?

0 Likes

#7

Nothing at all. That’s what stumped me, so I assumed it was my code. I only posted here after having stripped away parts, one by one, until I literally had an empty project. A nice “Running slowly? Use the –-verify-graphics-calls=false flag!” message would have saved a lot of time.

0 Likes

#8

Yes, I did find a couple of mentions after I realised there was an issue with debug. A warning/error message in the console would have been the best, that’s where I looked first.

0 Likes