Error occurred to liveupdate.settings (DEF-3386) (SOLVED)

#1

I submitted this as an issue to github as well.

This happens to new and existing projects:

3 Likes

#2

Ping @Johan_Beck-Noren, @Mathias_Westerdahl and @sven

3 Likes

#3

Yes, I can reproduce it too. We’ll take a look at it on monday.

If you want to use the old versions, you can get them by reading this link:
E.g.
1.2.132: http://d.defold.com/editor2/09410355c1baf7e474e46cbc2d252f67f673e1dc/editor2/Defold-x86_64-darwin.dmg
1.2.131: http://d.defold.com/editor2/091e7e02ce492d3c4e493324b9db57d40df69e95/editor2/Defold-x86_64-darwin.dmg

4 Likes

#4

We haven’t solved it fully yet, but we have a workaround at least.
The issue is when we create a new /liveupdate.settings file from scratch. You can work around it by saving a creating a file with this initial content in it:

[liveupdate]
supported-versions = 0.0.0

After that, you will be able to edit it in the editor as usual

5 Likes

#5

Now we have. Released in 1.2.135

2 Likes