Editor slowing down & becoming unusable (SOLVED)

#1

Opened Defold today and while only having scripts open it runs perfectly fine. As soon as I open anything graphical, such as a tilemap, tilesource, or collection, and my mouse enters that tab display window, everything slows down and I can’t click inside that tab.
If I move the mouse outside of the display/central tab and leave it a few seconds, everything else is fine (change properties, outline, change to another tab etc).

The rest of my computer is running fine, and I’ve never encountered this issue before. I’ve tried restarting computer, deleting and re-downloading Defold, change display settings from extend (2 monitors) to only 1 monitor or duplicate.
My game itself runs fine, both in Debug (F5) and Build (Ctrl+B) modes.

I am running Windows 10 with latest updates to everything (including graphics, which is Intel HD4000).
Latest Defold update 1.2.152

0 Likes

#2

I think the problem may be due to Windows,like one drive sync, data caching, windows defender, etc.

0 Likes

#3

Thanks @cocosgames , I’ve tried disabling/closing onedrive/google drive/dropbox, disabled defender firewall (can’t figure out how to disable defender entirely anymore), run bleachbit (open source alternative to CCleaner) and cleaned out cache/unused files etc.
Closed a bunch of other open programs like Adobe update etc.
Nothing seems to have fixed the issue.

I’ve also tried other projects and starting a brand new project in Defold, but still the same.
Next up I’m going to try and run Manjaro (linux) in VM to see how the Linux version goes (although running in VM might result in the same issues).

0 Likes

#4

Just want to add that I have seen the same happen on Windows computers in the office.

0 Likes

#5

@Jerakin These office computers you mention, are they high end?

0 Likes

#6

@aurion.woodgate Can you please try this:
Click the help menu item, then profiler and then measure and show. Preferably when the editor is currently being slow.
measure_and_show
This should open a web page in you default browser with some profiling data for the editor.
Now save the web page (ctrl/command+s) and please attach the resulting files here as a zip archive.

4 Likes

#7

Created internal issue DEFEDIT-1680 to track this.

3 Likes

#8

Also, if you look at the editor2 log files (Select Show Logs from the Help menu), is there something that is repeated over and over at the end of the log file when this happens?

2 Likes

#9

Hi @markus.gustavsson , I’ve attached zip file with the profiler data20190514 0815 profiler.zip (102.2 KB) from update 1.2.152

and
20190514 0831 profiler.zip (102.1 KB)
from update 1.2.153

@mats.gisselson It is mostly just checking for a new updates, and unpacking files. I can add log file to zip as well if you want to take a look?

Also of note:
I am not having this problem on my laptop, only on the desktop, also running latest updates to Defold/Windows 10 etc.
Laptop: Core i5 4200u / 4gb DDR3 / Intel Graphics (onboard)
Desktop: Core i7 3770k / 8gb DDR3 / Intel Graphics (onboard)
Both use SATA SSDs (no HDDs)

EDIT: I have tried Defold in Manjaro (linux) using Oracle’s VM Virtual Box inside Windows 10 on the Desktop. Although it is overall quite slow, I’m not getting the same hang up as I was in Windows, so it is definitely an issue within Windows somewhere.
Profiler for comparison: 20190514 0949 profiler linux.zip (100.4 KB)

1 Like

#10

Thank you for the feedback. Please add the log file as well. We expect to look into this further later this week or the next.

3 Likes

#11

editor2.2019-05-14 0833.log.zip (13.8 KB)

Here is the log file, hope it helps!

2 Likes

#12

Good news @markus.gustavsson @mats.gisselson @Jerakin !!
The editor is now working as it should be!
Windows 10 completed some updates today, did a restart, and everything is back to normal.

The list of Updates installed 16/05/2019: (DD/MM/YYYY)

  • Definition Update - KB2267602 (Definition 1.293.1667.0)

Updates installed 15/05/2019 (I’m sure these were actually installed 16/05/2019, but Windows lists them as the 15th):

  • Definition Update - KB2267602 (Definition 1.293.1647.0)

  • Definition Update - KB2267602 (Definition 1.293.1593.0)

  • Windows Malicious Software Removal Tool May 2019 - KB890830

  • Culmulative Update Windows 10 V1809 - KB4494441

  • Secutiy Update for Adobe Flash Player - KB4497932

  • Culmulative Update for .NET Framework 3.5, 4.7.2 & 4.8 - KB4499405

Hopefully this sheds some light on what might have happened. As I said, some, if not all, of the updates listed as installed on the 15th, actually came through on the 16th (perhaps they downloaded the day before?). I had a quick look at the update descriptions and the only one I could see with any real information seems to be KB4494441 listed here.

3 Likes

#13

I am glad that the issue is resolved for you. We will still look into it to see if we can figure out why it happened in order to prevent it from occurring again.

2 Likes