"Download Update" button doesn't work

#1

Dear Defolder,
When I press the button “Download Update”, it closes the prompt, does not start any downloads, and the “Update Available” text reappears.
Env: macOS 10.14.6 (18G1012) SSD
I didn’t post this as a bug because I don’t know how to diagnose it, considering it isn’t an editor bug or in-engine bug, but rather an actual Defold bug.
For the time being, I can manually install updates but I’d appreciate being able to fix this at some point!
Thanks for reading!
grify

1 Like

#2

Could you please launch the editor from a terminal and share the output or share the editor log?

2 Likes

#3

I manually updated to the latest version so I cannot demonstrate until a new release is published, but when it is I can certainly post the logs, although I don’t know how to launch the editor from Terminal.

0 Likes

#4

Which os are you using?

1 Like

#5

a 2015 iMac

0 Likes

#6

Ok, so open a terminal window then type:

./path/to/Defold.app/Contents/MacOS/Defold

This should start Defold and all editor output gets printed to the terminal window

1 Like

#7

I have the same problem.
editor2.2020-09-21.txt (25.2 KB)

1 Like

#8

The error message “java.util.zip.ZipException: archive is not a ZIP archive” suggests that something is wrong with the update file. Is it perhaps a text file?

When you look at C:\\Users\\Sayuri\\AppData\\Local\\Temp\\defold-update9152221748344656048.zipproperties, what file size is it?
Does it extract properly if you try it? (i.e. is it a zip file?)
Or what if you open it in a text editor?

1 Like

#9

There is no such file. I closed the firewall and tried again but the result is same.

1 Like

#10

The log you shared says that it downloads the following update which is indeed a full editor update file:

https://d.defold.com/archive/0fc7ca5e7fe9fb66f5d692c4f015b313d875d884/editor-alpha/editor2/Defold-x86_64-win32.zip

Are you out of diskspace? Any antivirus software which might prevent the file from being downloaded or extracted?

0 Likes

#11

Have plenty of space and I only use windows security. Tried again after disabling security but nothing changed.

Defold is installed in C:\Defold mayde that’s why Defold can’t download the update ?

0 Likes

#12

Yes, that could be it. Try moving it to somewhere in your user home folder, like Desktop or Documents.

0 Likes

#13

Alright now I have the zip file. But it’s 0kb and there is nothing when I open it whit notepad. And new log gives the same error.

0 Likes

#14

Not sure what’s going on to be honest. My recommendation is to download the latest version from d.defold.com instead.

0 Likes