Divide by 0 error with .otf font (DEF-2509)


#1

I was attempting to create a new font using Google’s Noto Sans CJK JP font (available here: https://www.google.com/get/noto/)
When creating a new Font File, after setting the to the NotoSansCJKjp-Regular.otf file I received a divide by 0 error and the preview could not be generated.


#2

Hmm, there seems to be some problem with that font. I’ve tried to convert it to a ttf font using various tools and they all fail. My Mac is on the other hand able to view the otf font, so I’m sure there’s something we can do to fix this. I’ve created a ticket: DEF-2509


#3

Try using this set of fonts as an alternative?

https://typekit.com/lists/source-han-sans


#4

Thanks! I read there was an adobe version of the same font. You’ve saved me the trouble of trying to track it down! :smiley:


#5

@Pkeod Thanks for trying to find me an alternative, but I’m getting the same divide by 0 error with those Adobe fonts too.
Is it a problem with otf in general? Or is it the Japanese sets? Or just this font?

Kind Regards,
Sam


#6

It’s not a general problem wit otf fonts, I just tried to use one and it worked well. I’m not sure what’s causing the problem though…


#7

Have you tried restarting the editor?


#8

Yep. And tried on both Windows and Mac


#9

Ok. Can you send a screenshot of your font properties?


#10



#11

Thanks. I get the same error here. Creating an issue.


#12

Sorry, there’s already an issue. But adding this font to the one @britzl created… :slight_smile: