Defold works out the box with PuppyLinux FossaPup 64bit (in virtualbox)

#1

I wanted to see if Defold worked with puppy linux. It worked right out of the box in puppylinux running in virtualbox. Though virtualbox slows every down, I have not done anything to tweak VirtualBox. http://puppylinux.com/ This computer did not have linux so I wanted a small linux I have used before with ubuntu option. So just dl’d the iso started virtualbox added a virtual drive.

But my other computers dont have windows. and I wanted to make sure I can run defold on both systems. PuppyLInux, Mint Linux, and Win 10. Ive been using puppylinux since 2005 or 2006 on usually broken systems windows cant use. I have a laptop missing a screen, cd rom, and buttons got wet (daughter spilled hot cocoa on keyboard) and dropped down a flight of stairs (same daughter sigh). I just run linux on it and plug usb mouse and keyboard and vga or hdmi monitor.

There really was not an install just downloaded package for ubuntu from Defold homepage, extracted zip and double clicked defold and it ran fine. I built and ran ran the roids game. I also bundled the match fish game- but I could not get mouse to drag fish they did respond to mouse though by expanding and blinking. But it bundled it no errors for linux-debug.

Again you guys have impressed me and added a second step of reassurance.

I will definitely have to learn git now.

1 Like

#2

Defold should work well on Linux but since there’s so many different Linux distributions, window managers etc it’s hard to guarantee that everything works at all times. If you do run into problems make sure to check if there is a solution in the FAQ: https://defold.com/manuals/linux/#faq

2 Likes

#3

It pleases me you guys support linux. I shouldnt have any problems with linux. Virtual box is another matter.

Thanks !

2 Likes