Defold won't let me upload a file into a tile source

I downloaded the new update and every time I try to upload a file into a tile source or tile map, the mouse turns into a loading rainbow circle thing and I can’t click anything. I also let it load for a long time and experimented with smaller and bigger files, and it still ended up this way. What do I do, it’s frustrating when I can’t upload my tilesets. It was working earlier.

What do you mean by upload? When you click here to select an image?

It should be instant.

You can always go back to an older version. Here is the previous one: Release v1.4.7 - stable · defold/defold · GitHub

But I would prefer if we could figure out what is wrong. Are you using Windows, Linux or macOS?

1 Like

Mac OS. And yes, I tried to upload the image and before it was instant. I just tried to upload an image again and it’s still happening.

Edit: I went with another version and it still behaves this way.

I just re-downloaded the editor and tried to upload an image into a tile source and it’s doing it again, I really want to use Defold because of how minimalist the engine is compared to other engines but I think I’m going to be forced to use godot.

Could you please record using Quicktime and share the .mov here?

I use Defold on macOS every day and have not encountered any issue like this.

I don’t know how to do that but I took a screenshot

edit: i just noticed that the mouse being turned into a rainbow circle doesn’t show up.

And what image do you select? DImensions? Format?

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Super easy:

An asset I downloaded from itchio. i don’t know the specifics.

An error occurred and it says: /Users/[name of computer]/Desktop/My Project/main/Modern_Exteriors_Complete_Tileset_32x32.png (No such file or directory)

edit: another error:

java.lang.AssertionError: Assert failed: (and root (.isDirectory root))

edit: another error:

java.lang.UnsupportedOperationException: Flush is forbidden from target!

edit: I tried to upload the image again and it did it again

It did it again after uploading the image

Perhaps you could share the image here?

It was paid and we aren’t allowed to share it but heres the link to what i bought

edit: heres some info. 5.3 mb, 5632x8032 dimensions

Defold on my mini m1 stops responding when trying to add an image of these huge dimensions to a tile source, just like on your mac. You’ll need to choose a smaller one I guess. Do normal sized images work (say 2048 x 2048 or smaller)?

Woah. That’s big. It will turn into a 8k texture taking up a whopping ~260MB of memory uncompressed. And it is 352 by 502 16x16px tiles. It sounds a bit wild if this is a single tileset?

Its 32px32px and the reason I’m using the big one because defold doesn’t support using separate tileset for one map so I thought that I would use the mega tileset, the tileset that had every single tile. I just experimented using a much smaller tileset and everything works perfectly.

So I guess my only problem is how I’m going to get defold to create a map with multiple tilesource. Is that possible?

Its doing the thing again, like how big of a file can I not do without the engine slowing down?

4096x4096 should be fine. You’d likely need to split it to multiple tile maps if it needs to be bigger than that.

It’s a bug, please report an isssue on github.

1 Like