Defold not starting on one Windows machine and not another (SOLVED)

#1

Sorry, not sure if this is the right place.

Describe the bug (REQUIRED)
click on defold.exe, splash screen appears, then goes off, nothing else happens.
This is occurring on a PC but not the identical PC next to it (same make, model, Windows 10 image and version)

To Reproduce (REQUIRED)
Click exe on certain PC

Expected behaviour (REQUIRED)
Defold to launch.

Defold version (REQUIRED):
latest

Platforms (REQUIRED):

  • Platforms: Windows
  • OS: Windows 10
  • Device:

Logs (OPTIONAL):
below file was in the defold folder, but was not created every time I ran it, most of the time get nothing.
defold error.txt (54.0 KB)

Additional context (OPTIONAL):
This is in a school environment, so the PC’s in the room are domain joined and identical with the same OS image and applications etc. I can’t find a difference between a PC that is working and one that isn’t. it doesn’t work for me as a domain admin or on students account on the effected PC’s.
I have tried searching for a solution but haven’t come across anything.
Any help, much appreciated.

0 Likes

#2

Test installing Defold into an %appdata%\ folder instead of Program Files?

0 Likes

#3

Hi, Thanks.
The result is the same but with what appears to be the same txt file created that I have attached.

0 Likes

#4

It looks like a problem creating the window. Does the two PCs have the same graphics card and driver version?

0 Likes

#5

I logged in launched it before testing checking drivers and it has just worked, despite me restarting the PC multiple times yesterday. what has changed I don’t know.
Thank you for your help anyway.
Regards
Rob

2 Likes

#6

It stopped working again :weary: .
I tried to check the graphics driver version and that didn’t open either, updated the graphics drivers and it appears to be working again.
Thank you for the help.
Regards

1 Like

#7

Happy to hear your got it working again. The log file did indicate a driver problem so it’s not surprising that a driver update fixed the problem.

0 Likes