Defold not running on Windows 7 x64 (SOLVED)

#1

Hi, I am new to Defold and I have downloaded the editor but for some reason it does not show up. In task manager I can clearly see that it is running but nothing is showing up, not even a single error or anything.

System I am running is Window 7 Professional 64-bit
Defold is located in this path directory : C:\Program Files (x86)\Defold
I have tried reinstalling Java JRE ( not sure if that would help anyway) and still no results.

Seems I’m the first person with this problem and would really appreciate if someone would help me with it as I am really interested in checking this engine out.

Thank you.

1 Like

#2

It could be the spaces in the path, namely the ones in “Program Files (x86)”. Could you try, just to verify, to put it in C:\Defold or something similar (ie. without spaces)? :slight_smile:

0 Likes

#3

Just changed it to C:\Defold and get same result as nothing is showing up.

Side note: Thanks for quick reply!

1 Like

#4

Darnit! :slight_smile: Could you check what the file Defold/workspace/.metadata/.log says?

0 Likes

#5

I have no clue what could be wrong based on that log file but here’s Whole log from that file.

1 Like

#6

Strange, I’m not sure the output of that file actually gave me much to go on… Hm, did you try force-closing the running instance before restarting it? Do you have more than one display? (Since it’s not a crash, the editor just does not show, maybe it could have something to do with different desktops/displays.)

One more thing to try; remove the .metadata folder inside your workspace directory. Or preferably, download the editor once again and unzip into a path without spaces. This should, I think, result in a fresh install.

0 Likes

#7

Before I posted this query, it was running in the background which eventually, I, later on, force-closed it as it was pointless service running on my laptop. No I do not have more than one display as currently I am using laptop. I have tried with deleting .metadata folder but result was the same. I have redownloaded Defold, removed old files and extracted new files straight into C:\Defold. I can see it running in the background but there’s nothing else except that.

0 Likes

#8

Try to execute java -version in console.

1 Like

#9

java version "1.8.0_77"
Java™ SE Runtime Environment (build 1.8.0_77-b03)
Java HotSpot™ Client VM (build 25.77-b03, mixed mode, sharing)

This is result from Cmd after using java -version

0 Likes

#10

Okay I do not know what just happened but the Defold just opened up.

I do not know how it manage to open up this time.

Thanks for the help!

2 Likes

#11

Hah, alright, awesome then!

Please report back if you run into this again!

2 Likes

#12

I have realised the problem now. Problem that I had was it takes really, really long time to load which made me think that it didn’t want to start.

  • EDIT-
    It also takes really long time to build and run
0 Likes

#13

In window 7 still loading from a 2 hour? But not opening the editor? Why

0 Likes

#14

How much time it takes ? I wait fro 2 hour.

0 Likes

#15

The editor starts in a min or something about that (it depends on hardware)
I’m not sure I understand what’s wrong in your case? Does the editor just hang on the splash screen?
Could you pls upload your logs? (how to find a path to the logs: https://github.com/defold/editor2-issues/blob/master/faq/logs.md)

0 Likes

#16

I know where the logs but what to do now?

0 Likes

#17

As @AGulev pointed out, upload the log(s) so we can view it/them.

Try attaching it as a reply right here on the forums, there is a “attach” button in the reply view:
image

If you can attach it directly, you can try compressing it in a Zip file, or in last case just paste the content directly as a reply.

1 Like