Defold not open in MacOS 10.9

Hi!

I’m just trying to install defold on my old-fashion Mac with OS version 10.9.5 (cuz I noticed that the minimum requirement is 10.7).

However, the app I installed just exit once I open it. I’ve tried several times without even seeing the user interface.

Any idea?

Btw, I’ve try the unix executable file on app content, here’s how the terminal reports:

Alright:~ usr_name$ /Applications/Defold.app/Contents/MacOS/Defold ; exit;
INFO:TOOLS: Launcher version 8894457f85514465165401c664f5ba79a7730804
DEBUG:TOOLS: arg 0: /Applications/Defold.app/Contents/Resources/packages/jdk11.0.1-p1/bin/java
DEBUG:TOOLS: arg 1: -cp
DEBUG:TOOLS: arg 2: /Applications/Defold.app/Contents/Resources/packages/defold-229b4dbc78495615871b3a7679e79d75d018c27a.jar
DEBUG:TOOLS: arg 3: -Xdock:icon=/Applications/Defold.app/Contents/Resources/logo.icns
DEBUG:TOOLS: arg 4: -Xdock:name=Defold
DEBUG:TOOLS: arg 5: -Dfile.encoding=UTF-8
DEBUG:TOOLS: arg 6: -Djna.nosys=true
DEBUG:TOOLS: arg 7: -Ddefold.launcherpath=/Applications/Defold.app/Contents/MacOS/Defold
DEBUG:TOOLS: arg 8: -Ddefold.resourcespath=/Applications/Defold.app/Contents/Resources
DEBUG:TOOLS: arg 9: -Ddefold.version=1.2.189
DEBUG:TOOLS: arg 10: -Ddefold.editor.sha1=229b4dbc78495615871b3a7679e79d75d018c27a
DEBUG:TOOLS: arg 11: -Ddefold.engine.sha1=8894457f85514465165401c664f5ba79a7730804
DEBUG:TOOLS: arg 12: -Ddefold.buildtime=2021-11-18T07:28:45.493342
DEBUG:TOOLS: arg 13: -Ddefold.channel=editor-alpha
DEBUG:TOOLS: arg 14: -Ddefold.archive.domain=d.defold.com
DEBUG:TOOLS: arg 15: -Djava.net.preferIPv4Stack=true
DEBUG:TOOLS: arg 16: -Dsun.net.client.defaultConnectTimeout=30000
DEBUG:TOOLS: arg 17: -Dsun.net.client.defaultReadTimeout=30000
DEBUG:TOOLS: arg 18: -Djogl.texture.notexrect=true
DEBUG:TOOLS: arg 19: -Dglass.accessible.force=false
DEBUG:TOOLS: arg 20: --illegal-access=warn
DEBUG:TOOLS: arg 21: --add-opens=java.base/java.lang=ALL-UNNAMED
DEBUG:TOOLS: arg 22: --add-opens=java.desktop/sun.awt=ALL-UNNAMED
DEBUG:TOOLS: arg 23: --add-opens=java.desktop/sun.java2d.opengl=ALL-UNNAMED
DEBUG:TOOLS: arg 24: --add-opens=java.xml/com.sun.org.apache.xerces.internal.jaxp=ALL-UNNAMED
DEBUG:TOOLS: arg 25: -Xmx3221225472
DEBUG:TOOLS: arg 26: com.defold.editor.Main
DEBUG:TOOLS: arg 27: (null)
dyld: Registered code signature for /Applications/Defold.app/Contents/Resources/packages/jdk11.0.1-p1/lib/server/libjvm.dylib
Picked up JAVA_TOOL_OPTIONS: 
Picked up _JAVA_OPTIONS: 
2021-12-03 15:28:22.942 WARN  default    javafx - Unsupported JavaFX configuration: classes were loaded from 'unnamed module @6ff11957'
dyld: Registered code signature for /Users/god/.openjfx/cache/18-ea+6/libprism_es2.dylib
dyld: Registered code signature for /Users/god/.openjfx/cache/18-ea+6/libglass.dylib
2021-12-03 15:28:23.211 Defold[82049:6b03] ERROR: macOS version is 10.9, which is below the minimum of 10.12
Exception in thread "main" java.lang.RuntimeException: java.lang.ExceptionInInitializerError
	at com.sun.javafx.tk.quantum.QuantumToolkit.startup(QuantumToolkit.java:301)
	at com.sun.javafx.application.PlatformImpl.startup(PlatformImpl.java:293)
	at com.sun.javafx.application.PlatformImpl.startup(PlatformImpl.java:163)
	at com.sun.javafx.application.LauncherImpl.startToolkit(LauncherImpl.java:659)
	at com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:679)
	at com.sun.javafx.application.LauncherImpl.lambda$launchApplication$2(LauncherImpl.java:196)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ExceptionInInitializerError
	at com.sun.glass.ui.mac.MacPlatformFactory.createApplication(MacPlatformFactory.java:36)
	at com.sun.glass.ui.Application.run(Application.java:146)
	at com.sun.javafx.tk.quantum.QuantumToolkit.startup(QuantumToolkit.java:291)
	... 6 more
Caused by: java.lang.RuntimeException: Unsupported macOS version
	at com.sun.glass.ui.mac.MacApplication._initIDs(Native Method)
	at com.sun.glass.ui.mac.MacApplication.<clinit>(MacApplication.java:55)
	... 9 more
logout

ok, i saw the “Unsupported macOS version”

sad day with my old laptop :worried:

It seems like the JavaFX update we did recently bumped minimum supported macOS version. Sorry about that!

3 Likes

So would you tell me the version without the update :joy:

Btw, time to update the defold.com page

I think the 1.2.188 editor is the one with the older JavaFX:

1 Like

Hello everybody,

First of all I hope you are all doing great.

Today I had the same problem. I tried to start defold on my Mac and I couldn’t do it. It was odd. I then downloaded the latest version and still did not open. Then I went into the package files and launched the terminal and I got the terrible news:

`2021-12-18 19:59:35.286 Defold[5559:1185105] ERROR: macOS version is 10.11, which is below the minimum of 10.12`

I then download the version 1.2.188 and it opens ok.

So, do you think there is going to be a way I can overcome this? Or am I doomed to become obsolete?

Thank you very much and Merry Christmas!

We recently updated JavaFX to fix an issue on macOS Monterey and this had the side effect of raising the minimum supported version to 10.12.

If you have the ability to build Defold yourself you can downgrade JavaFX in the build configuration.

1 Like

My old dev Mac is on 10.13.6 and can’t be (officially) updated. The end is near!

When mine is no longer useful as a Defold dev machine for macOS / iOS, I’m going to turn mine into a dedicated Linux box.

3 Likes

Hello everyone and thank you for your answer.

Oh, ok, so there is a solution, yeeeeeyyy!

Yep, mine is already there, boooo…

Uuuh, maybe you could post a sort of tutorial on that matter. :+1:

Anyway, thanks again, I’ll see if I am able to rebuild Defold with the older JavaFX.

Greetings and Happy Holidays!

This is the change you want to make and then build: https://github.com/defold/defold/commit/229b4dbc78495615871b3a7679e79d75d018c27a#diff-62a7f829ebf062330784a9427edadff0c0094d61c43fdee752e6f0b9b8ffff08