Defold crashes on sparky linux- EDITED

Hi again. On Sparky Linux, I can start Defold, load a sample project, do some lite editing. but building a project or changing collections in editor causes defold to suddenly close. Suggestions? In task manager it terminates when closes.

Thanks JB
EDIT:<<<<< I added the error log file I found when I ran it in terminal.

hs_err_pid22967.txt (235.4 KB)

Since your log refers to “ffi”, you can try this tip from our FAQ


I tried these fixes:

Q: The Defold editor crashes when opening a collection or game object and the crash refers to

A: The libffi version of your distribution and the one required by Defold (version 6 or 7) does not match. Make sure or is installed under /usr/lib/x86_64-linux-gnu. You can download like this:

$ wget
$ sudo dpkg -i libffi7_3.3-6_amd64.deb

Next you specify the path to this version in the LD_PRELOAD environment variable when running Defold:

$ LD_PRELOAD=/usr/lib/x86_64-linux-gnu/ ./Defold

I had same result.

Ok I got it working.

I did these same steps again- but as root from the defold folder. Now I can build, run, and change collections.

I don’t know why this worked when done from the defold directory versus just the terminal.