Defold and IE11 incompatibility (issue-4719)

#1

@aglitchman It is my understanding that IE10 and below doesn’t support WebGL. So even if you fix the missing AudioContext the game wouldn’t run?

1 Like

Big List of Defold Pro Tips!
#2

@britzl Yes, it wouldn’t run on browsers that doesn’t support WebGL.

Offtopic

We’ve been developing HTML5 solitaire games for a website with an unusual audience - 15% of users uses IE11. That’s why we still need IE11 support in Defold even without audio fx.

1 Like

#3

Ah, I see. Sorry, I got minimum browser versions mixed up for WebGL and AudioContext. Indeed, then there’s a thin slice of IE11 users (2.4%) that can’t use Defold. We should perhaps add your patch to the default HTML template…

BTW, I saw that you had a patch for gamepads as well.Do you get a crash without it on some browser versions?

2 Likes

#4

Yes, it’s for IE11, too. Defold engine crashes at GLFW.refreshJoysticks on startup because Gamepad API is not implemented at all.

0 Likes

#5

Does it happen even if you remove value(leave it empty) in game.project->input->gamepads?

0 Likes

#6

I’ve just tried: HTML5 build with empty Input -> Gamepads is crashing on loading.

Summary

2 Likes

#7

Could you please share the full error message you have in IE11?

0 Likes

#8

4 Likes