Defold 1.2.158 has been released

#1

Defold 1.2.158

This release includes mainly bug fixes related to bundling. It also fixes an issue with HTTP requests which made the HTTP cache not behave correctly.

We also fixed the gui.get_world_rotation() function so that it removes any scale applied to the transform before returning the rotation.

Engine

  • #4241 - Fixed: Bundling broken in 1.2.157 on Windows due to path issues.
  • #4240 - Fixed: When bundle_resources was empty some files would incorrectly be copied raw during bundle.
  • #4228 - Fixed: Issue with “Content-length” header in HTTP requests.
  • #4226 - Fixed: Issue where values from multiple setting files weren’t stored built game.project.
  • #3463 - Fixed: Bug in world rotation (DEF-2032).

Editor

  • DEFEDIT-1603 - Added: Filter and search in game.project.
  • #4197 - Added: Make tabs reorderable by dragging.
  • #4188 - Fixed: New file dialog was incorrectly filtering out slashes.
19 Likes

Files from "common" folder when building html 5 (SOLVED)
Defold 1.2.157 has been released
Bob.jar ignoring custom settings via --settings flag (#4226)(SOLVED)
Game object's scale affects its world rotation [DEF-2032] (SOLVED)
pinned globally #2
0 Likes

#3

Thank you for fixing the bundling issue! I can finally release my game :smile:

4 Likes

#4

I just installed this update and now whenever I try to open Defold it gives me and error message. Please help

0 Likes

#5

What does error message say?

0 Likes

#6

java.lang.NoClassDefFoundError:clojure/data/json$fn__9557$fn__9558

0 Likes

#7

I don’t know if this is related to the new release, but I cannot make a build in HTML5 today. When the build application says “Proceed to select output folder” I don’t get a file selection window.
And then when I break the build application off, all menus are grayed out and Defold won’t close and I have to force stop it.

I’m working on a Macbook pro. with with macOS Catalina version 10.15 beta.

I’m rather new to Defold, so this could be me doing something wrong.

2 Likes

#8

@vlaaad did we change the bundle dialog?

1 Like

#9

We haven’t done any changes to bundle dialog, and I can build html5 projects… Can you check if logs contain any errors? (Help → Show Logs)

1 Like

#10

editor2.2019-07-18.txt (186.7 KB)

I’m not sure what to look for. here’s my log.
I tried to make a build just 20 min ago.

0 Likes

#11

Unfortunately, can’t see anything suspicious in the logs. Does it happen on every project, or only on some projects?

0 Likes

#12

Actually I can’t build any of the bundles and it happens in any project.

I can build and run and build HTML directly on my system, just not to any bundle.

I don’t get a fileselector and then when I press Create bundle… then Defold hangs.

0 Likes

#13

If it happens all the time, I suspect that Catalina beta may cause this problem. Every mac OS version comes with new java problems. It is better not to update it for a year.

1 Like

#14

This is JDK issue in macOS 10.15 beta
https://bugs.openjdk.java.net/browse/JDK-8227836

We will check what we can do with that.

At the moment workaround is using of the bob.jar for bundling on macOS 10.15 beta.

UPD: The issue for a future tracking https://github.com/defold/editor2-issues/issues/2688

3 Likes

#15

Might very well be the beta. thanks for the advice and for the heads-up.
I’ll consider going back to Mojave, if things get worse, but for now I prefer to find workarounds and stay ahead with projects in swift UI.

1 Like

#16

@t.ybema
Could you try adding Defold.app to this list in “System Preferences” -> “Security & Privacy”?

This was a workaround for Mojave before we updated JavaFX, but maybe it’s something similar again? Just a wild guess.

0 Likes

#17

will do, thanks

1 Like

#18

Thanks, but didn’t work for me.

0 Likes

#19

Note: the issue is not in JavaFX, it’s in Java, so we’ll have to update used JDK version once they’ll release the fix.

1 Like

#20

Thanks for the tips guys. I’m glad there is a workaround.
Now I’ll start to get friendly with Bob. :wink:

5 Likes