Defold 1.2.142 has been released


#1

Defold 1.2.142

This release adds better manifest verification for Liveupdate where it will verify that the expected bundled resources are actually available in the bundled application.

It’s now possible to exclude either 2D, 3D or both physics engines. By default, Defold is built with both 2D and 3D physics. With the app manifest, you can now choose to use only one or none of them. You can choose between physics_2d, physics_3d and physics_null. E.g for only using the 2D physics engine, add to your game.appmanifest:

   excludeLibs: ["physics"]
   libs: ["physics_2d"]

The HTML template has been moved to the builtins/manifests/web folder to make it easier to create your own custom template, or just verifying changes between updates. There are also a couple of fixes related to the new WebAssembly platform and some optimizations for building HTML5 on the Native Extensions server.

Engine

  • DEF-3555 - Added: Liveupdate manifest verification now verifies that expected bundled resources are actually in the bundle.
  • DEF-3097 - Added: Support for excluding specific physics engines.
  • DEF-3625 - Changed: Moved HTML5 template to builtins.
  • DEF-3605 - Changed: Higher max number (16) of material constants for model/sprite/label.
  • DEF-3607 - Fixed: Issue with pprint and single value arguments.
  • DEF-3602 - Fixed: Removed the console window on release builds on Windows (NE).
  • DEF-3585 - Fixed: null pointer crash in IapGooglePlayActivity.
  • DEF-3569 - Fixed: Bundled binary names are now sanitized.
  • DEF-3606 - Fixed: Missing linker option for wasm-web on vanilla builds.
  • DEF-3604 - Fixed: Missing wasm-web platform in variant appmanifests.
  • DEF-3614 - Fixed: Optimized HTML5 builds on NE server.
  • DEF-3610 - Fixed: Crash in Spine model with wasm-web on MS Edge.
  • DEF-3122 - Fixed: Issue with mouse emulation on mobile (single frame taps).

#2

The update will be available from the editor shortly.


pinned globally #3

#4

Something wrong with raptor’s legs?


test.zip (3.8 MB)


#5

I don’t think this is a new thing.
This is 1.2.141 (slowed down to 10%)
https://imgur.com/UTN3CwT

For reference, this is the original
https://imgur.com/V6oJP0y

Defold probably don’t support the IKs in combination with meshes properly.

Looking the animation over and comparing to Defold I can see a lot of discrepancies between how the meshes are rendered/deformed.


Added two tickets for the issues, doesn’t seem to be the combination of them.



#6

Is there someplace I can download the most recent version? Mine isn’t automatically updating properly so I just downloaded the Windows 64-bit version from the dashboard, but it’s still 1.2.141.


#7

That sounds strange… Downloading the MacOS editor from from the dashboard gives me version 1.2.142;
46


#8

Yeah, the same dashboard menu I’m using.

Hmm. Is there some install process that I need to do? I just deleted the stuff in my old ‘Defold’ folder (packages folder, config, and defold.exe) and replaced them with the ones from the zip. In the help>>about screen it says 1.2.141, and in the console when I run a project.

[Edit] OK, just downloaded the 32-bit version. It is 1.2.142.


#9

Downloading the 64-bit windows looks like the correct version and SHA1 of the engine as well. Could you open the config file in the downloaded zip check the version and checksum? It should look something like:

...
[build]
version = 1.2.142
editor_sha1 = dad5cf07671cbbe4040b69122128f834d379c7e2
engine_sha1 = 6230c40dfa051a311aa4005c19097574e062374d
time = 2018-11-20T13:31:19.072623
channel = editor-alpha
...

#10

OK. I just triple-checked the 64-bit zip I downloaded a couple hours ago. Its config looks like this:

[build]
version = 1.2.141
editor_sha1 = dfbd3470660278721c7a0eea27f9e57d53590564
engine_sha1 = 738e2ebc3cba56027fa00ca27706019bb772871c
time = 2018-11-14T10:25:11.486561
channel = editor-alpha

The 32 bit version has the correct config info.


#11

Strange. A CDN or cache issue perhaps?


#12

Yeah, I guess so. I will clear the cache and try again to see.

Yup, that worked. Thanks guys! I will remember that in the future.