Crash while using run with debugger on Ubuntu


#1

Running version 1.2.142 on 64-bit Ubuntu
Defold crashes while Building or running the debugger on any project
Screenshot%20from%202018-11-21%2001-56-02

Is this related to https://github.com/defold/editor2-issues/issues/716 ?


Defold crashes on Ubuntu
#2

Hmm… the engine output in the console says the engine crashed, and the admittedly ugly error message means the editor couldn’t connect to the part of the debugger running in the engine. Please share the _crash file and someone on the engine team can have a look. @sven?


#3

Possibly an opengl/mesa related issue again, but in the engine this time :slight_smile:


#4

Perhaps that message can be parsed too by the editor and the file could be scooped up with the error reporting too?


#5

_crash.zip (1.1 KB)
Here is the _crash file. Zipped it to upload.


#6

Thx.
Looking at the callstack in the _crash file, it definitely seems OpenGL related.
What version are you running?


#7

OpenGL version string: 3.1 (Core Profile) Mesa 17.2.8


#8

Does it list the supported extensions for OpenGL? It would be interesting to know the list, I think it might be related to the crash.


#10

Supported extensions:

OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.2.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
GL_ANGLE_texture_compression_dxt3, GL_ANGLE_texture_compression_dxt5,
GL_APPLE_texture_max_level, GL_EXT_base_instance,
GL_EXT_blend_func_extended, GL_EXT_blend_minmax, GL_EXT_buffer_storage,
GL_EXT_clip_cull_distance, GL_EXT_color_buffer_float,
GL_EXT_compressed_ETC1_RGB8_sub_texture, GL_EXT_copy_image,
GL_EXT_discard_framebuffer, GL_EXT_draw_buffers,
GL_EXT_draw_buffers_indexed, GL_EXT_draw_elements_base_vertex,
GL_EXT_frag_depth, GL_EXT_geometry_point_size, GL_EXT_geometry_shader,
GL_EXT_gpu_shader5, GL_EXT_map_buffer_range, GL_EXT_multi_draw_arrays,
GL_EXT_polygon_offset_clamp, GL_EXT_primitive_bounding_box,
GL_EXT_read_format_bgra, GL_EXT_robustness,
GL_EXT_separate_shader_objects, GL_EXT_shader_integer_mix,
GL_EXT_shader_io_blocks, GL_EXT_tessellation_point_size,
GL_EXT_tessellation_shader, GL_EXT_texture_border_clamp,
GL_EXT_texture_buffer, GL_EXT_texture_compression_dxt1,
GL_EXT_texture_cube_map_array, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_format_BGRA8888, GL_EXT_texture_rg,
GL_EXT_texture_sRGB_decode, GL_EXT_texture_type_2_10_10_10_REV,
GL_EXT_unpack_subimage, GL_KHR_context_flush_control, GL_KHR_debug,
GL_KHR_no_error, GL_KHR_robust_buffer_access_behavior, GL_KHR_robustness,
GL_MESA_shader_integer_functions, GL_NV_draw_buffers,
GL_NV_fbo_color_attachments, GL_NV_image_formats, GL_NV_read_buffer,
GL_NV_read_depth, GL_NV_read_depth_stencil, GL_NV_read_stencil,
GL_OES_EGL_image, GL_OES_EGL_image_external, GL_OES_EGL_sync,
GL_OES_compressed_ETC1_RGB8_texture, GL_OES_copy_image, GL_OES_depth24,
GL_OES_depth_texture, GL_OES_depth_texture_cube_map,
GL_OES_draw_buffers_indexed, GL_OES_draw_elements_base_vertex,
GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,
GL_OES_geometry_point_size, GL_OES_geometry_shader,
GL_OES_get_program_binary, GL_OES_gpu_shader5, GL_OES_mapbuffer,
GL_OES_packed_depth_stencil, GL_OES_primitive_bounding_box,
GL_OES_rgb8_rgba8, GL_OES_sample_shading, GL_OES_sample_variables,
GL_OES_shader_image_atomic, GL_OES_shader_io_blocks,
GL_OES_shader_multisample_interpolation, GL_OES_standard_derivatives,
GL_OES_stencil8, GL_OES_surfaceless_context,
GL_OES_tessellation_point_size, GL_OES_tessellation_shader,
GL_OES_texture_3D, GL_OES_texture_border_clamp, GL_OES_texture_buffer,
GL_OES_texture_cube_map_array, GL_OES_texture_float,
GL_OES_texture_float_linear, GL_OES_texture_half_float,
GL_OES_texture_half_float_linear, GL_OES_texture_npot,
GL_OES_texture_stencil8, GL_OES_texture_storage_multisample_2d_array,
GL_OES_vertex_array_object, GL_OES_vertex_half_float,
GL_OES_viewport_array


#11

Thx!
The callstack says that something goes wrong when we parse these supported extensions, in particular the “GL_EXT_discard_framebuffer”. I’ll look into it more tomorrow!
Unfortunately, I don’t have a good workaround for you.

But, I’m curious, has this worked for you before? Does the engine only crash when you have the debugger attached?


#12

It works fine on the same pc running Windows 10.

Defold won’t build the project or run the debugger on Ubuntu.


#13

Does the graphics card report the same extensions on Windows?

“Defold won’t build the project or run the debugger on Ubuntu.”

Have you reported the building step not working in another thread/issue? If so, where?

“Ubuntu”

Which version of Ubuntu?

“…run the debugger on Ubuntu.”

What if you don’t run with the debugger? Just the engine itself?


#14

no

Ubuntu 64 bit 17.10

i get a black screen

and nothing else


#15

I have 2 small screencasts to show the problem.


I can run the same project without problem on the same pc running Windows


#16

Almost sounds like an exploration day :slight_smile:


#17

Hi @skg! From those videos it looks like the MESA workaround didn’t actually work properly. Can you go to Help > Show Logs and send me the latest log file from a session where you’ve gotten this completely black scene editor?


#18

_crash and log file.zip (86.8 KB)

Here is the latest _crash and log files.


#19

Did the log file help?

Defold otherwise seems to run ok. I tested a project created on Windows 10, and it ran fine over WiFi on my device, solid 60 fps. :slight_smile:

BTW is there a way to test the app on android emulator having x86 image?


#20

Hi @skg,
Sorry, haven’t had time to look into this issue yet. Are you running Ubuntu in some virtual machine under Windows?


#21

No I haven’t tried running it under Virtual machine.

It is a dual booted machine with the specs:
Ryzen 5 1600
16GB DDR4 RAM
R7 250 1GB DDR5 Graphics
Windows 10 64 bit + Ubuntu 17.10 64 bit

Running the same version of Defold(1.2.142) on Windows and Ubuntu.
Windows has no problems.

Ubuntu can create new projects, open projects, generate apk files, etc. but

  1. Cannot open files like .collection, .atlas etc : get a black screen as shown in video above. But I can open .script files without any problem.
  2. Cannot run the debugger (F5 shortcut) or use Build command(Ctrl + B) : get a crash message as mentioned above.

I have tried running the legacy version of Defold which runs fine but lacks features. Hope it gets fixed soon.

Thanks.