Collection Proxy load causes error in Gooey on second proxy load

#1

I am using collection proxies to switch between menus from the main menu of Chemaria. I am also using Gooey for UI stuff.

Running from the editor causes no issues, but bundling the app causes problems (I have tried both Windows and HTML5). The first time going to my load game screen populates the list and everything works fine. If I leave and come back, this error shows up in the debug console
ERROR:SCRIPT: gooey/internal/core.lua:81: Node used in the wrong scene stack traceback: [C]: in function 'get_parent' gooey/internal/core.lua:81: in function 'is_enabled' gooey/internal/list.lua:99: in function 'get_instance' gooey/internal/list.lua:273: in function 'dynamic' gooey/gooey.lua:126: in function 'dynamic_list' main/menus/load_game_menu/load_game_menu.gui_script:34: in function 'fill_save_list' main/menus/load_game_menu/load_game_menu.gui_script:115: in function <main/menus/load_game_menu/load_game_menu.gui_script:101>
Looking at the Gooey code, it essentially is just using the base gui functions to check if the node exists and if it’s parents are valid.

My code mentioned in the trace is this

gooey.dynamic_list("save_list", "save_list/stencil", "save_list/listitem_bg", self.saveFiles, actionId, action, on_item_selected, update_save_list).scroll_to(0, self.scrollbar.scroll.y)

Does anyone have an idea why this would only be happening on a bundled build? The only other special thing happening is that I am using the Defold LFS native extension to query the directory for files.

1 Like

#2

Are you using the latest version of Gooey? Can you share the project with me (bjorn.ritzl@king.com) or a minimal repro case?

0 Likes

#3

I take from master on Gooey, which I know may not be the best practice because of breaking updates, but it allows us to find weird things like this too. :laughing: Sending you the email now.

0 Likes

#4

Did you send me an email?

0 Likes

#5


Yes I did.

0 Likes

#6

Nope, I can’t see it. Is the attachment large? Can you try and resend or share some other way?

0 Likes

#7

You can clone the repo from here: https://gitlab.com/JamesOrson/Chemaria/tree/minimal-proxy-error

0 Likes

#8

I get the same error on android when I install the apk. Main menu has vertical list with gooey, coming back to it throws this same error. It does work when I use the engine on the device. Switching between screens is done with monarch. For now I let it be as I was not sure I would keep the menu like this, but as you opened the topic I thought to mention it.

0 Likes

#9

I’ve released a new version of Gooey that solves the problem. Would you mind trying again?

2 Likes

#10

It works! Thanks! What exactly was happening?

0 Likes

#11

We changed the way the script instance is stored in the global table and the change I did to Gooey a while back to handle this didn’t work for html5 (and apparently also not for Windows?).

0 Likes

#12

Interesting. I wonder if it has to do with me being on the Insider Preview of Windows 10?

0 Likes