Collection error on linux (SOLVED)

I installed Linux distribution named Solus on my computer and I’m trying to use Defold on it. But everytime when I go to main.collection It’s not loading and It’s showing this:
Does anyboy know how to fix it?
Thank you.

Check if this solution from the Linux FAQ fixes it.

1 Like

Thank you very much, it works, but only if I run the command always I run Defold. Is it possible to set it up permanently without having to run the command again every time I want to run Defold?

Setting it permanently would probably break some other app. What you can do is save the command in a .sh file so that it’s easy to re-run.


Thank you very much, It’s working perfectly.

If you want to go one step further, you can create a launcher for it so it will appear in your “start menu”.

Not sure about Solus, but in Linux Mint you can just right-click on the “start menu” button and select “Edit Applications”. It starts up a program called “Menulibre”, AKA: “Menu Editor” (or you can start it from a terminal). It gives you a decent GUI interface for making launcher files for your programs, like so:

Set the “Command” to your .sh file that you made.
You can give it an icon, such as:

And then you can launch it from your menu, all professional-like!
whoops! *quickly scribbles out Unity*…


Thank you very much, that is exactly what i did. But very great tutorial. :grinning: