Cannot delete a project (SOLVED)


#1

Hi there, for some reason I cannot delete a project that I don’t need from the dashboard.
Here is the error I receive when pressing ‘DELETE FOREVER’ button:
image
I have been unable to do it for a long time now, I thought it was some bug, but it was never fixed.


#2

It sure sounds like a bug. Thanks for reporting. Ping @samuel.nystedt and @anon18330549


#3

Hey @BeLuckyDaf—sorry for the inconvenience, and thanks for reporting the issue. I can’t reproduce the issue; could you invite axel.hammarback@king.com to the project in question? Also—what OS/browser are you on?

Thanks


#4

Added you to the project @anon18330549 . This particular time I was using Google Chrome, but as far as I have tried, it works in any browser, on any device.


#5

Just found out that errors come and go all the time. This one appears just when I load the page, I think it speaks for itself, probably the repo got deleted somehow, and the project remained.
image

UPDATE: Yep, there’s certainly no repo.
image


#6

Deleting a project from the dashboard does not wipe your local copy. Does the project show up in the dashboard project list or how do you get to the faulty dashboard page?


#7

Yes it does show up in the list and I don’t have a local copy, since I created this project a long time ago and changed several PCs since that time. I can change the name and description, but I can neither delete the project, nor download the remote copy.


And it also shows up in the list of projects in the engine, but when I click ‘import project’, it shows the error, that I posted in the previous message.


#8

@BeLuckyDaf not an ideal solution – but since I’m in the project, you can transfer the ownership to me, and leave the project yourself. Then it at least won’t appear in your dashboard ¯\_(ツ)_/¯


#9

@anon18330549, that is what I am going to do then. Would be nice to know what caused this behavior anyway. Could be somehow related to the creation of a community page. Just a thought.


#10

Yeah, I agree. I can try to do some investigation now that I have the project. I’ll let you know if I find out what the issue is.


#11

Maybe the project is haunted? Just be careful when messing around with it!


#12

Now that I’m digging around in it… the very last commit was done on this very day—5,000 years ago :open_mouth:


#13

We have now patched this bug and it was released this morning. Sorry for the inconvenience!