Can only build with HTML5 in Defold Editor 2 (SOLVED)


#1

I’m running Defold 2 on 32 bit windows (with a 64 bit processor if it helps, and yes I know that’s bad) and I was just trying to try out the sidescroller tutorial as the first step. The blue link in the readme and Project > Build do not work, with the Build Errors tab being full of “Compilation failed: null” errors. Project > Rebuild has the same effect. However, Project > Build HTML5 yields the editor for a few minutes then runs the project on the browser normally. But I’d like to have it build without HTML5, so how do I do that?


#2

Have you tried installing the x64 version of Defold and trying to build the project through that?


#3

Are there any more informative error messages in the tab? What happens if you try to bundle for windows? Could you send me the editors log files (find them using Help>Show Logs)? Thanks!


#5

Can’t find it right now but when people have had trouble on win32 it’s often because the application runs out of memory. Changing the jvm -Xmx flags etc in the config file sometimes helps!


#6

I’ll answer to both of your posts:

  1. I cleared the previous logs and restarted the application to open the tutorial project and attempt to build it. Now I think that was probably a mistake, but have a look and see:
    (Your uploader doesn’t allow text files so here’s a pastebin) https://pastebin.com/Yt1QFMqs
  2. I can’t see what you’re talking about in the config file. Can you show me where I should be looking?

#7

Nothing obvious in the logs. The config file should lie next to the editor exe. We might have removed the memory related flags though. Can you build if you start a new empty project?


#8

The config file is where you say it is (I was looking at it the entire time) but there really is nothing that looks like “jvm -Xmx”. Also, building an empty project still resulted in compilation failed: null for the one and only script inside. Building with HTML5 works… but not much to see.


#9

Alright, so the error “Compilation failed: …” comes from a failed attempt to run luajit. Would you mind trying to run the editor under an account with a less exotic user name? Could be that luajit (or our method of running it) chokes on !or whitespaces.


#10

Oh right! The account I’m using right now has both exclamation marks AND whitespaces… the former has usually been the culprit of Java applications not working, so I believe we found the issue. Thank you very much, Mr. Angelin!
Now I’d rather rename the current user (and their folder) so I’m going to do that. Bit risky but I’ll do all the backups necessary and hope for the best. I’ll edit this post if Defold works after all.


#11

Hi @Marios! Just curious, did it work with another account name?


#12

Ah, forgive me for forgetting. I went through some troubles (which were exclusively my fault) but in the end, a new account name without spaces or other special characters works like a charm. Thank you for your concern, but I have no more need of it. Good day!